Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I suspend my laptop, I am unable to do optirun/primusrun because it can't activate the gpu.

[ 8597.514526] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 8597.515142] [INFO]Configured driver: nvidia
[ 8597.515421] [DEBUG]optirun version 3.2.1 starting...
[ 8597.515456] [DEBUG]Active configuration:
[ 8597.515474] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 8597.515496] [DEBUG] X display: :8
[ 8597.515506] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia
[ 8597.515517] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 8597.515527] [DEBUG] Accel/display bridge: auto
[ 8597.515536] [DEBUG] VGL Compression: proxy
[ 8597.515546] [DEBUG] VGLrun extra options:
[ 8597.515555] [DEBUG] Primus LD Path: /usr/lib/primus:/usr/lib32/primus
[ 8597.515639] [DEBUG]Using auto-detected bridge virtualgl
[ 8597.575176] [INFO]Response: No - error: XORG NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 8597.575194] [ERROR]Cannot access secondary GPU - error: XORG NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 8597.575202] [DEBUG]Socket closed.
[ 8597.575217] [WARN]The Bumblebee server was not available.

I tried some quirks with pm-suspend but nothing really worked. Any ideas what I can do?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The same happened to my laptop today after upgrading the kernel. Debian & bumblebee.

In my case the module bbswitch was missing, so I used dkms to build it for the actual kernel version.

  • Check kernel version:
    uname -a (3.12.9, for example)

  • Install bbswitch ready for dkms:
    sudo apt-get install dkms-bbswitch (0.8 version, for example)

    (I don't know if kernel-headers is required. Install if necessary)

  • Build/install bbswitch:
    sudo dkms install -v 0.8 bbswitch -k 3.12.9

  • Restart bumblebeed if necessary:
    sudo service bumblebeed restart

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.