Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open a new tab in Firefox, my most visited sites appear in a grid. How do I get rid of this? Not that I'm trying to hide anything :). It's just that having Facebook keep popping up all the time. It is distracting me from my work.

share|improve this question
add comment

6 Answers

up vote 1 down vote accepted

Enable or disable the Google new tab page

  1. Click the Toolbar's wrench icon.

    wrench

  2. On the Search tab, select (or deselect) the 'Enable the Google new tab page' checkbox.
  3. Click Save.

Google Help Article With Video

share|improve this answer
    
The link is broken now. –  romkyns Dec 17 '12 at 22:40
    
The question is for Firefox, not for Google Chrome. –  Nicolas Barbulesco Oct 5 '13 at 8:13
add comment

As of Firefox 13, this new tab page has become a built-in feature.

To disable it, you can click the grid icon on the top right corner of the page:

Screenshot of icon

Alternatively, you can navigate to about:config, search for browser.newtabpage.enabled and double click it to set it to false (or set the browser.newtab.url to about:blank or whatever). This is the setting the grid icon toggles.

Of course, if you have an extension such as Google Toolbar or New Tab King providing the page as suggested in the other answers, this method won't work. This method is only to disable the built-in most visited new tab page in Firefox 13 and newer.

share|improve this answer
1  
Thank god. That is absolutely the most bletcherous "feature" I've been subjected to as an "upgrade" in ages. –  dmckee Jun 13 '12 at 17:42
    
@dmckee As long as it's possible to disable, it's all good :) It's those 'features' that can't be disabled/reverted that are a pain... –  Bob Jun 14 '12 at 11:49
    
"browser.newtab.url" = "about:blank" also helps Firefox feel faster, at least on underpowered machines. –  romkyns Dec 17 '12 at 22:42
add comment

Here's how to remove the New Tab King extension from Firefox:

  1. Click on the Firefox menu and select "Add-ons"
  2. Click on "Extensions", then find New Tab King in the list and click on "Remove"

You will be sent to a page asking you why you are removing the extension. Feel free to ignore it.

share|improve this answer
    
Also, you will benefit from installing this add on after you follow the above removal of the King Tab extension. addons.mozilla.org/en-US/firefox/addon/new-tab-homepage –  Stargate Jun 11 '12 at 20:47
add comment

this is the answer. It's the "enable the google new tab page" in the google toolbar options

share|improve this answer
add comment

This isn't normal behavior. You should be getting a blank page.

It's most probably an add-on that you have installed, maybe New Tab King.

Find the add-on and disable it to get rid of this behavior.

share|improve this answer
1  
i'm using google toolbar yes, maybe it's an option on that, i'll have a look... –  conspirisi Oct 23 '09 at 10:55
add comment

I don't know if there is another way but this should work:

Tools->Addons, disable "Google Toolbar for Firefox"
share|improve this answer
    
ahh probably google toolbar...i don't want to disable that one though –  conspirisi Oct 23 '09 at 10:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.