Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a RAID5 array on my computer, 3X 200GB sata drives. Everything has worked great forever but all of a sudden when I turn it on the BIOS shows that only two of the three drives are functioning. The last drive shows up as "Unknown Disk". The array itself shows up as not boot-able as a result. I assumed this wouldn't even be a problem (isn't that what RAID5 is for anyway?) but no matter what I try I can't get it to boot. Even if the third drive is removed from the computer completely. Any ideas? Thanks!

share|improve this question
add comment

2 Answers

There isnt enough information to say what happened. But it sounds like you had a catastrophic failure, like a power surge. It could be the drives are damaged, or the RAID controller itself. RAID protects you from the loss of a drive. However, it does not protect you from corruption. Nor does it protect your from the loss of multiple drives (depending on RAID setup). It definitely sounds like you lost a drive and the fact that the array still wont boot, it would appear you may be out of luck. You need to test the RAID controller for functionality, as well as the individual drives. Hopefully, you have a backup.

share|improve this answer
    
Thanks for the advice, how would I go about testing the RAID controller? –  Blake May 10 '13 at 17:59
1  
if you have some spare drives, see if you can create a new raid on them –  Keltari May 10 '13 at 18:16
    
I don't really have any on hand that aren't being used for something. Any kind of utility I could burn to a disc etc and boot to that would run diagnostics like that? –  Blake May 10 '13 at 21:16
1  
do you have a backup of your data? If so you can create a mirror on the two disks that wont boot just to see if its working properly. Beyond that, there isnt much else you can do... unless your RAID BIOS has some kind of built in test –  Keltari May 10 '13 at 22:01
    
I do of the files but not the OS etc. I'll have to see if I can round up a few extra drives and try your first idea. –  Blake May 11 '13 at 4:01
add comment
up vote 0 down vote accepted

After a few days of working on this I finally got it up again. It turned out not to be an issue with the RAID controller or a power surge or anything like that. The one drive was shot but the others are perfectly fine. What finally fixed it was super simple, I went into a part of the RAID setup and it must have run some sort of check or repair in the background because it immediately changed the status to "Degraded" - since it did lose one drive and then allowed it to boot. Now all that's left is to order a replacement for the defective drive. For some reason it just wasn't recognizing the degraded array as bootable until that point. If anyone is having this issue I would first go into the RAID configuration upon boot up and go through all of the settings. In my case I didn't even have to change any of them, just going into the config area fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.