Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two PCs both running Vista Home Premium (64-bit). They are each connected to the internet wirelessly. However in order to make file transfers between them go quicker they are also directly connected with a gigabit network cable. They are both assigned static IPs for the wired connection - 10.0.0.1 and 10.0.0.2. The IPs for the wireless connection are in the 192.168.. range.

Every time Vista boots up it sets that wired network to Public, which means that neither PC can see the other one. I then have to change it on both computers to private before it can be used. When changing it to private it won't let me give the network a name.

Is there any way to force that network to start as private by default that doesn't involve buying extra hardware?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Try this:

Open the Local Security Policy Editor (Start->Run "secpol.msc" ).

Under Security Settings, select "Network List Manager Policies" and then select the wired network name from the displayed network names. Right-click and select Properties and set the "Location type" to Private. Then reboot.

If it doesn't work for the wired network, try it also for "Unidentified Networks".

share|improve this answer
    
This sounds like it should do the trick. The only issue is that the Local Security Policy Editor doesn't come with the Home versions of Vista. Any idea where the settings it would change live in the registry? –  Adam Nov 10 '09 at 10:29
    
See if this helps : social.technet.microsoft.com/Forums/en-US/itprovistanetworking/… –  harrymc Nov 10 '09 at 13:22
add comment

If you are not able to ping 10.0.0.1 -> 10.0.0.2, you will need a crossover cable, or need to plug both computers into a switch/hub.

share|improve this answer
    
I can ping 10.0.0.1 <-> 10.0.0.2, but only once the network has been change to private at both ends. This change to private needs to be done after each reboot, which isn't very convenient. –  Adam Oct 26 '09 at 9:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.