Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed OpenSUSE 11.1 on my Elonex Webbook as I want to start playing with Mono.

Unfortunately, there seems to be some problem with the video card, and it only seems to recognise it as VESA, and won't give me a higher resolution than 800x600.

The video card (VIA Unichrome Pro II apparently), will support 1024x600, but OpenSuse won't have it.

I have been able to successfully run this netbook on 1024x600 on Windows (XP and Win7), and on Ubuntu, however, I'd much rather use OpenSuse as its Novell backed (as is Mono...)

Would appreciate any suggestions, and please bear in mind, I'm a newbie on Linux (at the moment)....

Oh, and I have tried changing the xorg.conf file following these instructions but that also didn't work.

Have also installed the openChrome driver from here but that also doesn't give me anything.

I have also tried changing the screen resolution in the graphics app on opensuse, and that, while it does say 1024x600, and tests ok, doesn't boot on it.

Many thanks


EDIT: The output of the xrandr command is

Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600

default connected 800x600+0+0 0m x 0mm

   800x600        75.0*

EDIT2: I've also tried putting Ubuntu Netbook Remix on there, and that doesn't allow me to complete the install, as it changes the graphics mode to something I can't see. I guess I need to install, using a monitor, then change it... Shame I can't get opensuse working though.

share|improve this question
up vote 1 down vote accepted

I've modified the xorg.conf file with

sudo nano /etc/X11/xorg.conf

and made the following changes:

    Identifier "Configured Video Device"
    Driver "openchrome"
    Option "PanelSize" "1024x600"

Section "Monitor"
    Indentifier "Configured Monitor"
    DisplaySize 221 129 # 117 DPI @ 1024x600 Opiton "noDDC"

which appears to work quite well. However, I have swapped to Ubuntu (9.1 now), which has the openchrome driver for the Elonex Webbook included.

share|improve this answer

Please post the output of the command 'xrandr', it will list your available resolution, the same command can also be used to manually set the resolution using 'xrandr -s 1024x768' or the resolution you desire.

share|improve this answer
Hi there, I've updated the question to add that in. Cheers! :) – Nick Haslam Oct 23 '09 at 15:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .