Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I change the volume in VLC, Rhythmbox, or a video on YouTube, it change the master volume, i.e. the system volume. How can I prevent this from happening?

I'm running Debian 7.0.0 (wheezy) with xfce4, it seems to use PulseAudio, which I'm not familiar with. Here's a screenshot of the "Mixer" app that comes with xfce:

enter image description here

Yes I tried unchecking the "chain" icon there. I installed pavucontrol but there seems to be no option to change that:

enter image description here

share|improve this question

1 Answer 1

This Gentoo wiki article might apply here : PulseAudio per-application volume control :

PulseAudio supports per-application volume control, but by default this doesn't do much as you can only control these volumes from the pulseaudio volume control utility. Meaning that in an application like Audacious, when the output device is set to PulseAudio, and the volume control is set to hardware, it will adjust the master volume control, not the per-application volume control.

To fix this behavior, set the following in /etc/pulse/daemon.conf

flat-volumes = no

Now whenever Audacious goes to adjust the volume, it will adjust the audacious only volume and thus you wont have multiple applications fighting over the master volume control.

share|improve this answer
    
Thanks, but it did NOT work. Both changing the volume from the pulseaudio GUI (as seen here) and from the application itself (here) change the system volume. I rebooted the computer after making the changes. I checked the file and the changes were indeed saved –  Alex May 14 '13 at 15:04
    
Debian wheezy apparently uses PulseAudio version 2.0-6.1. You might try out the above advice on version 3.0-1 available on the experimental distribution. –  harrymc May 14 '13 at 16:58
    
@Alex Right. I'd bet on the problem being Debian-specific as PulseAudio and PA-enabled apps have worked the way you want for many years. –  Michael Hampton May 19 '13 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.