Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently purchased a Lenovo y500 and installed Debian wheezy 64-bit on it with no issues. The problem I'm having is with the touchpad. In Windows (dual boot) it ignores movements on the lower part of the track pad which is used for clicking. In Debian however, the entire touchpad is detected for movements. Thus, when I click, it responds the the slight movements I make on the touchpad while pushing it down. This is especially bothersome when right clicking which often results in my inadvertently selecting a menu option when I release the button.

Is there some way I can configure Debian to ignore movements on a certain area of the touchpad?

share|improve this question
The info in this thread might be helpful for Debian too. – Karan May 11 '13 at 1:24
@Karan this kinda works but it then reads all of my right clicks as left clicks. weird. – xhainingx May 11 '13 at 1:58

In principle you can achieve this with:

$ synclient AreaBottomEdge=1822

After this I could not paint an area of text by clicking the button and moving another finger on the mouse pad. The result is not identical to a touchpad with buttons that are not part of the pad. The cursor does not move when the button area of the touchpad is touched regardless of the movement of the other finger.

More information: Arch Linux info on Synaptics

And naturally:

$ man synaptics

I hope someone could give a better solution, but I hope this helps you to get started.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.