Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have used Unetbootin on one of my USB drive, and it seems to have partitioned it some way that it's no longer recognized by any OS. It's not even listed when I turn on my computer and press F12 to list the boot options.

I have tried to use GParted and even OpenSuse Partioner but none of them were able to recognize the drive. However I'm still able to hear that sound when I plug it in, meaning that a USB device has been connected. On Windows, I can see it listed in the device manager but can't get it to work.

share|improve this question

1 Answer 1

Usually it helps to clear the first sector of that device. So on Linux, try this as non-root:

  • insert the usb drive, check dmesg to see what device it gets asigned (assuming /dev/sdc here)

  • dd if=/dev/zero of=/dev/sdc bs=512 count=1

  • fdisk /dev/sdc (add a partition in here)

  • mkfs.vfat /dev/sdc1 (or any other filesystem you want)

share|improve this answer
    
Thanks for your answer. It's not working though, but I think we're getting closer : the last line of dmesg is "[ 126.489702] sd 7:0:0:0: [sdc] Attached SCSI removable disk" and /dev/sdc is created when I insert the drive. But then when I run the second command, I get this error message : "dd: opening ‘/dev/sdc’: No medium found" –  iamdede May 11 '13 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.