Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently moved from bash to ZSH and oh-my-zsh (which is so far wonderful) and installed it in my desktop, laptop and hosting (dreamhost) with a theme called agnoster.

I also installed solarized and the custom powerline-patched font in both gnome-terminal (Dekstop) and iTerm2 (OSX), so in both o these I get everything to work just fine

enter image description here

and even if I use SSH to connect to my Desktop from my laptop I see everything working.

The problem is, when I changed the default shell in Dreamhost to zsh, installed oh-my-zsh and agnoster, it just shows:

{black}{default} user@dreamhost {blue}{black}⮀{black} ~ {blue}⮀

enter image description here

(The arrows work for me) but the colors are not shown properly, just as a string.

I have looked for a solution everywhere but I can't seem to find what is causing this, did anyone ever encounter such a problem or knows any way to fix this?

Thanks in advance everyone!

share|improve this question

migrated from stackoverflow.com May 11 '13 at 18:06

This question came from our site for professional and enthusiast programmers.

    
Can you clarify please? Zsh is a shell, not a terminal. If you changed your terminal to zsh, change it back; if you changed your default shell to zsh, please edit your question. –  dave4420 May 10 '13 at 14:32
    
@dave4420 my bad, I actually meant I changed my default shell to zsh (from bash, which was the default) from the dreamhost control panel –  juanlu May 10 '13 at 15:31
    
Additional information is probably required. Check the zsh version (zsh --version) both locally and remotely. Are you using identical zsh files on both boxes (and how sure are you about that)? What are the zsh options (setopt)? What does the code for the PROMPT look like? –  simont May 11 '13 at 3:54
add comment

1 Answer

up vote 1 down vote accepted

Solved it!

Thanks to @simont for giving me the clue about what the problem could be about: Version!

I did as he said and run zsh --version on both working machines and Dreamhost, resulting in Dreamhost having 4.3.6, which is far lower than the 5.0.0 version found on the working machines.

Solution Steps

  1. SSH Dreamhost
  2. Download the latest version of zsh from their website. (use wget, curl ...)
  3. Extract everything tar zxfv zsg.tar.gz
  4. cd zsh/
  5. ./configure --prefix=$HOME/local
  6. make
  7. make install

Now just change your SSH command to ssh username@host.dreamhost.com -t local/bin/zsh or, as I did, make a new alias in your local machine (be it ~/.bashrc, ~/.zshrc or whichever shell you use) to avoid the extra typing.

Thanks a lot guys for your help!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.