Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows 7 Home Premium SP1. When firefox is running, and I click the "+" to add a tab, firefox launches yahoo in the new tab, instead of my home page. How do I correct this?

Here is a screenshot of the situation:

firefox new tab issu Firefox version is listed in this screenshot:

Firefox version

Answer

The New Tab Homepage extension had stopped working. I disabled it and then used both answers below as two concurrent steps. I used SearchReset @MrMAG linked in his answer, then used about:config that @AthomSfere recommended to reconfigure the new tab homepage.

share|improve this question
up vote 5 down vote accepted

In firefox, in the Address bar type about:config

Search for newtab:

enter image description here

Double click that option, and change it to your requested home page for a new tab.

share|improve this answer
    
I changed the browser.newtab.url but it still opens yahoo. specifically: search.yahoo.com/… – Ben Plont May 12 '13 at 4:28
1  
Once I disabled an extension called New Tab Homepage, this worked. – Ben Plont May 13 '13 at 16:52

Try to use the SearchReset extension to reset some preferences to the default values.

Note:
This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. (it won't show on the "Firefox > Add-ons" page (about:addons))
This affects the search bar, URL bar searches, and the home page.

share|improve this answer
    
I did this, which did exactly what it was supposed to, but noticed that I needed to do some maintenance with the add-ons. I disabled the New-Tab homepage extension, and then changed the newtab.url back to what I wanted it to be. I'm up voting both answers, because they were both steps in the process that worked. Thanks. – Ben Plont May 13 '13 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .