Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old PC which I want to use for internet browsing. I tried using Puppy Linux (version 4.3.1) for the same but have not been able to connect.

I connect via PPPoE. My network card is RTL 8029b which is automatically detected by Puppy Linux. However, the LED indicator on the MODEM designating LAN connectivity stays off. This post is being typed from the same PC running XP, so there are no connection issues.

I am a complete newbie with Linux. Can somebody point me to instructions? I will be willing to give any more information if required.

My modem is a Huewei Smartax MT 882

Thanks

share|improve this question
    
if it runs XP, it should run a lighter weight linux that isn't based off older kernels- maybe give debian or lubuntu a try with unetbootin to see if they perform better? –  Journeyman Geek Oct 19 '11 at 7:19
add comment

3 Answers

Presumably you can actually shutdown from your network connected XP system
and reboot with PuppyLinux to find that the Ethernet port remains in a link-down state.

This is very curious;
I would expect compatibility or configuration problems to surface as
an inability to dial-up your ADSL connection -- not as a physical link-state problem.

Maybe someone here knows if a driver (or its default configuration)
could cause such an effect.
Particularly, after the RTL card has been successfully detected (like you state).

As a next step maybe you could get some diagnostic information out for reference.
Check this PuppyLinux packaging of the lshw tool.
You could probably update your question with the RTL card details from that.

share|improve this answer
    
yes, it does stay in link down state from the moment XP shuts down. The link up state as seen via the indicator LED come moments before the actual XP desktop is visible. As I am a complete newbie where linux is concerned, i might also have to figure out how to run the tool that you suggest :( –  Vaibhav Garg Oct 24 '09 at 3:48
    
Is the card functioning when you start computer into Linux directly? It is a known D3 problem - windows sets device in deepest powersave state and BIOS does not bring them up on soft reboot. –  ZaB Feb 22 '12 at 12:08
add comment

First, check that your linux see everything connected by using the command "ethtool eth0" - you'll have to do this as root. You should see a message "Link detected: yes". If not, then you've got a hardware link problem.

The next thing I would suspect is that Linux is not setting the port up for DHCP. When you bring up the linux box, check on the ethernet port with "ifconfig" - it should tell you many things, including the IP address of the port. If not, you may need to assign one, or set the box into DHCP mode so that it can request an address.

share|improve this answer
add comment

Your network card is fixed at 10Mbps Maybe Huawei did not test with such card.

If the card has other than TP connector (or even if it is set to full-duplex) you might need to use ethtool and/or mii-tool (both included on ubuntu live-cd) to make the PHY to work in 10baset/half duplex

Alternatively (or if miitool/ethtool are of no help) you might need to figure out real manufacturer of the card (which is NOT realtek) and use their DOS config utility to change PHY setting.

This card has NO DMA thus it will load CPU fully when working at 10Mbps. I would suggest you ask admins at work if thwy have some Intel or DEC/Tulip 100Mbps cards, if they have no more - go and buy a RTL8111/8168 based Gigabit card at 5-10$ - they may not be perfect for gigabit on server but for 100Mbps they do all checksum offload with DMA for 100Mbps.

share|improve this answer
    
The same works with Window XP with the same modem, as indicated in the OP itself. This is not likely to be an issue. –  Vaibhav Garg Feb 22 '12 at 11:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.