Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently downgraded from Windows 8 to Windows 7 on my Laptop. I know it has 2 USB 3.0 ports (the blue sockets). I'm currently using the "Intel 7 Series C216" chipset .

The problem is, I tried installing the "Intel USB 3.0 eXtensible Host Controller" driver, and it wouldn't let me. Opening setup.exe would give the "this system does not meet the minimum requirements..." message. I also tried manually updating the usb host controller by directing it to the inf files through Device Manager. However, it says it's incompatible and the device wouldn't start.

Any help would be appreciated.


I use an ASUS K55A laptop with i7 3630QM. The Chipset is Intel HM76.


Link to


I have 2 USB 3.0 and 1 USB 2.0 sockets. Could the USB 2.0 controller be interfering with the USB 3.0?


This is what my Device Manager looks like

share|improve this question
try the driver 1.​0.​8.​251 from here:…. Also post which laptop you use. – magicandre1981 May 12 '13 at 5:22
I did try that version. I use an ASUS K55A laptop with i7 3630QM. The Chipset is Intel HM76. – Maxius May 12 '13 at 5:23
have you tried the driver from ASUS? If this also fails, upload the file "C:\Windows\Inf\" – magicandre1981 May 12 '13 at 5:27
Yes, I have also tried that one. – Maxius May 12 '13 at 5:29
As a follow up to this: Apparently, I had disabled some USB related option (Legacy Support I believe) in BIOS. Now that I have re-enabled it, USB 3.0 is back on my laptop. Sorry for the troubles. – Maxius May 14 '13 at 20:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.