Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a USB flash drive for which I want to use a custom icon. My autorun.inf looks like this:

[Autorun]
UseAutoPlay=1
Label=TrueCrypt Traveler Disk
Icon=Volume.ico
Action=Start TrueCrypt Background Task
Open=TrueCrypt\Windows\TrueCrypt.exe
shell\start=Start TrueCrypt Background Task
shell\start\command=TrueCrypt\Windows\TrueCrypt.exe
shell\dismount=Dismount all TrueCrypt volumes
shell\dismount\command=TrueCrypt\Windows\TrueCrypt.exe /q /d

...but the icon doesn't appear, and nothing happens when I attach the drive - no dialog box, etc. I can still access it via "My Computer", but it doesn't have the icon. I've already set all options in the "AutoPlay" properties tab to "Prompt me each time to choose an action", but that doesn't fix anything.

I know this question has (probably) already been asked before, but the search feature gave me nothing. HOWEVER, this question is more centered on getting the icon working than getting auto-exec to work.

I'm running Windows XP Home Edition on this computer, but I will use it on Windows XP Professional and Windows 8 as well.

share|improve this question
1  
This might be obvious, but have you checked that the icon name is spelled correctly, and to include the full path to it? With the current configuration, the icon should be in the main USB folder, is it there? –  Sekhemty May 12 '13 at 18:59
    
@Sekhemty Yep - it's in the correct directory - Ubuntu recognizes it... –  JamesTheAwesomeDude May 14 '13 at 2:38
    
Please explain it: how Ubuntu recognizes it? These autorun.inf settings, AFAIK, will only work on Windows. Do you mean that you can open the .ico file with an image viewer? –  Sekhemty May 14 '13 at 21:40
    
@Sekhemty Ya, Ubuntu is designed to be as user-friendly as possible, so the developers added support for autorun.inf icons. I plugged it into the Ubuntu machine to perform a sanity check - making sure the icon is in the correct folder, double-checking autorun.inf's syntax, etc.. –  JamesTheAwesomeDude May 14 '13 at 23:41

1 Answer 1

Try setting the system attribute of the autorun.inf file. You'll need to set the system attribute from the commandline using something like:

attrib +S e:\autorun.inf
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.