Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently purchased a new desktop PC: HP p7-1423w, i5-3330, HD Graphics 2500 (integrated). The first thing I did was remove Windows 8 and install Linux. A few days later, I was ready to install a graphics card that I already owned (NVIDIA GEFORCE GT 610 -- PCI Express 2.0).

When I insert the graphics card and turn on power, I get beeping and there is no display from either the discrete or the integrated graphics.

I can remove the card and work with the BIOS, but there isn't any setting that seems like it would improve this situation.

I actually had the same problem a few days earlier with a totally different computer (Gateway/AMD), which I decided to return. This makes me think that the problem relates to Windows 8 and the newer "UEFI" BIOS associated with that.

Are there known problems and solutions for installing discrete graphics in computers that are designed for Windows 8 but now run only Linux?

share|improve this question
    
The problem arose not because of Win8 but because you used an old graphics card (the 610 is just a rebranded 520) that doesn't support UEFI. –  Karan May 17 '13 at 0:20
    
@Karan: Thanks for the info. Is this what you are talking about: Are there any video cards that support UEFI GOP? –  nobar May 17 '13 at 2:33
    
Yeah. Also see my comment here. Perhaps there's a similar UEFI update available for your card, but I highly doubt it (not much incentive to do so, even if the ROM size is adequate). –  Karan May 17 '13 at 2:36

1 Answer 1

I eventually got it to work by going into the security menu of the BIOS and setting the following:

  • Secure Boot: Disable
  • Legacy support: Enable

Other notes:

  • I had already disabled the "Secure Boot" option in order to install Linux.
  • There was a scary red warning box that told me that these settings only affect Windows 8.
  • I do not know if this solution is compatible with running Windows 8 (e.g. dual boot).
  • BIOS menus tend to not be very user friendly.

There are some other sources that provide this solution, but they are hard to find if you don't know that the problem specifically correlates to "Windows 8".

share|improve this answer
    
Funny story: A year and a half later, I wanted to boot Windows 8 (for the first time). I disconnected my Linux drive and reconnected my Windows drive. I get Error code 0xc0000001 "Your PC couldn't start properly" and it tells me to insert the install media, which I don't think I have. I resolved this by reverting the BIOS settings and removing the graphics card (which is a brand new one). I think it wanted to do the initial PC setup with the initial hardware. –  nobar Nov 1 at 2:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.