Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running a Debian Squeeze linux server on my Dlink DNS-320 NAS. I signed up for a DNS service, so I could access it from anywhere. I installed lighttpd, and created a very simple page to test. To finish the setup, I forwarded the ports on my router.

Everything worked exectly as expected, and I could access the dlink page. But when I tested it from outside of my local network, it didn't work. The request timed out.

I think the problem is in my hosts file, but I'm not sure. Here it is:

127.0.0.1 localhost.localdomain localhost
IpInMyNetwork MyNas MyNas

Where IpInMyNetwork is the actual IP of the NAS in my local network. What could I be doing wrong ? If there is any other necessary I am not providing, please let me know. I am relatively new to this area.

Any help is very appreciated, thank you

Edit

Hi, I double-checked, and my NAS doesn't have a firewall. Neither does my modem. My router does, but I set the NAS on DMZ so it shoudn't be a problem any more. I've tried changing the configuration to remotely access the router instead of the NAS, but I'm getting the error gateway time out

Edit 2

I was able to remotely access my router using port 8080 . There was clearly a problem with my previous choice of port (i was trying to use port 80). I will try to setup the NAS again and provide some feedback

Final Update

It turns out my ISP blocks port 80, it is the contract I signed. But I had no clue they did it. The solution was using other ports for SSH, FTP, HTTP...

share|improve this question
    
Ouch. I have heard some ISP do block some service ports (80 in your case) to prevent you from running a server or a business or a website behind them. They will happily remove that if you pay their premium business plan or something. You can try HTTPS (443) port, or use your own custom port as long as you remember what it is. The most common non-standard HTTP port is 8080, and hopefully your ISP doesn't block that. –  Darius May 16 '13 at 7:26

1 Answer 1

up vote 1 down vote accepted

(Not really an answer but a few things you can try)

When accessing from outside your local network, do you put in your router public IP address? (And then assuming you set your router correctly, any request to the router public IP will be redirected to your NAS)

Also do check your firewall (on Router, and on NAS).

Router may have its own firewall, so maybe try turning that off, and also try setting DMZ to your NAS just to eliminate some blocking/firewall issue. DMZ is pretty much "any traffic I have no idea about, I will simply forward to this IP" so if your router is blocking something, DMZ will allow that bypass.

Also your NAS (Debian Squeeze) may have its own firewall and blocking request from your router / public IP as it is not an expected traffic. So you can try turning that off temporarily.

Once you can connect to the NAS box from outside your LAN, you can raise the bar slowly (firewall on router, and firewall on NAS) and see which one does the block. And once you found out which one, make a rule to allow that incoming traffic.

Hopefully it helps.

share|improve this answer
    
Thank you very much for your answer. I thought about using DMZ, but I had no idea the NAS could have a firewall. I will try all these things as soon as I get back. I'll give you feedback when I do –  Luke May 13 '13 at 12:20
    
Hi, I double-checked, and my NAS doesn't have a firewall. Neither does my modem. My router does, but I set the NAS on DMZ so it shoudn't be a problem any more. I've tried changing the configuration to remotely access the router instead of the NAS, but I'm getting the error gateway time out –  Luke May 14 '13 at 4:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.