Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A large number of services (most of which appear to be core Windows services) are showing in services.msc with their service names rather than their display names (eg. BITS instead of Background Intelligent Transfer Service), and their description as 'Failed to Read Description. Error Code 2'.

I've tried running sfc /scannow as suggested in http://stackoverflow.com/questions/13153214/windows-service-is-giving-description-failed-to-read-description-error-code-2, but that hasn't worked.

Update (15/5): a large number of items in Group Policy Editor (gpedit.msc) are showing in the form @(name).dll,-(number). For example, under Windows Settings > Security Settings > Local Policies > Security Options, the first option is listed as '@appinfo.dll,-200'.

I'm guessing this is a MUI / resources issue from the format of those names...

The only thing I can think of that might have caused this kind of damage is the AMD Catalyst Uninstall Utility, which I ran shortly before I noticed the problem. In the log file for that, it mentions deleting the registry key SYSTEM\CurrentControlSet\Control\MUI\StringCacheSettings - is it safe to copy this key from another computer where everything's working to see if that fixes it?

share|improve this question
    
what is sfc telling you? Has is finished without any issues? Or was it unable to fix all damaged files. –  magicandre1981 May 13 '13 at 4:06
    
When I ran it before, it said it found and fixed all the issues it found (some changes required a reboot, which I performed). I've just run it again and it says Windows Resource Protection did not find any integrity violations.. –  TheRealSomeGuy May 13 '13 at 6:52
add comment

1 Answer

up vote 1 down vote accepted

Had the same issue. Copied that registry key mentioned from another machine and imported it and everything is working correctly now.

share|improve this answer
    
how did you do that? –  Alex Jun 11 '13 at 15:11
    
Yeah, I ended up trying this as well and it worked perfectly. –  TheRealSomeGuy Jun 12 '13 at 1:15
    
@axrwkr I just exported the value using regedit on another PC and then copied the file over to the computer with those messages and ran it. You could also just recreate the value yourself - by memory, it's just a single value. –  TheRealSomeGuy Jun 12 '13 at 1:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.