Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently decided to reinstall Windows 7 (32-bit) on my Acer Aspire 4745G laptop with Switchable Graphics. Using the Acer Resource DVD, I installed drivers,including the ones for my display adapters (ATI Mobility Radeon HD 5470 and Intel Graphics Media Accelerator), and thought everything was fine. But after the reboot, I was stuck on the 'Starting Windows' screen. I waited a few seconds and heard the Windows startup sound, which means only my screen froze. Tried a few times later but was still stuck. I then went into safe mode and checked the installed drivers. Saw that the AMD 5470 wasn't using any resources because it has a problem.

For the meantime, I uninstalled the driver software for both as I don't know if I did anything wrong. Went to Device Manager and checked the display adapters again. ATI 5470 seems to be experiencing this Code 10 error (This device cannot start.), while the Intel seems to be working fine. Any ideas on how I can fix these display adapters?

share|improve this question
    
Where did you get those drivers? –  gronostaj May 13 '13 at 12:05
    
@gronostaj I installed them from the Acer Resource CD. It was named 'AMD VGA Chip MADISON_PRO' in that cd. –  user223978 May 13 '13 at 12:34
add comment

1 Answer

Try downloading latest drivers from your laptop manufacturer's website. Don't use drivers provided by AMD, those won't work with hybrid graphics.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.