Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two Emacs instances running, one locally and the other as an X Window running on a server I am ssh-connected to. When I try to copy+paste text between one and the other, the instance running on the server can paste to the local one by selecting text and doing Meta+W, then doing Shift+Insert on the local Emacs buffer. But the other way doesn't work: by selecting text and doing Meta+W on the local Emacs then doing Shift+Insert on the server Emacs, I get either nothing, or the contents of the clipboard from another program (e.g. the browser).

I have the same .emacs file on both, so I am not sure what's making these behave differently. How can I make the Shift+Insert pasting work from local to server Emacs?

share|improve this question
up vote 2 down vote accepted

It works for me. Try adding the following into .emacs on the remote machine:

(setq x-select-enable-clipboard t)
share|improve this answer
    
brilliant! Thanks! – 719016 May 13 '13 at 13:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .