Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP Pavilion dv4-1101tu notebook. Currently it is running on Windows 7. All devices are installed correctly with their driver softwares.

When I make a call over Skype with my headphone plugged in, the call's sound goes through this headphone. But the weird thing is that if I open an audio file at the same time, the audio's sound will goes through the speaker. So I have tried to:

  • Change Windows default playback device to Independent headphones: Nothing happened. Also Windows default communication device can only be set to Speakers and Headphones.
  • Change Skype's audio setting to Independent headphones: Both call's and audio's sound will go through the speaker. The default setting is Speakers and Headphones.
  • Change settings in IDT Audio Control Panel: This panel does not allow me to change default playback device to my headphone.
  • Disable the speaker: No audio's sound anymore.

My playback settings look like this

playback settings

Can anybody help me please?

share|improve this question
    
When I play sound through my headphones, on the properties menu, the sound is shown going through the speakers (like the screenshot you have posted). Perhaps your configuration will only play through the headphone jack for VoIP. Try disabling the Independent Headphones, then test. –  Ben Plont May 13 '13 at 19:13

5 Answers 5

You can change default device as well as default communication device to headphones. That should take care of it.

share|improve this answer
    
Thanks but the problem is the default playback device can not be changed to headphone. I have updated my question regarding to this. –  user433531 May 13 '13 at 16:22

I think that you're telling the computer to only use the headphone for communications applications. When the headphones are plugged into the jack, the logic still outputs sound from applications like WMP and youTube to the speakers, because the headphone jack is reserved for communications applications like VoIP. I think that if you disable the headphones, the sound will play through the jack (and therefore the headphones) because the OS will release the jack to any sound playing app, not just communications...that's my theory.

share|improve this answer

I have toshiba laptop, which rarely has the same problem regarding switchover into headphone/headset. You can try:

  • input "Device manager" in windows search box
  • expand Sound, video and game controller, you might find the Audio device (in my case, I found 2 which were labeled as "High Definition Audio Device")
  • right click and Disable it/them
  • Repeat by Enable
  • go to Action > Scan for hardware changes, to make sure

Check again, which the output of the sound goes, and Sn'P (shrug and pray).

share|improve this answer

First, have you checked your Skype audio settings? Skype has the final say as to where its audio/video feeds go. This is so that you can set your system audio to your speakers, such as a game or video, but have a Skype call sent to the headphones so that it remains private and doesn't affect the other applications.

Second, you can right click on the speakers in the audio settings and select disable. This will force the audio to your headphones. Note: you will have to reverse this change when you are done.

share|improve this answer
    
Disabling the speakers will disable output of sound, in his current configuration. –  Ben Plont May 13 '13 at 20:36
    
@BenPlont It shouldn't, since he has the headphones available windows should either then allow him to set the headphones to the default sound device or automatically switch to them. If it does completely disable sound on the system the next time he activates the volume control windows will run the sound troubleshooter and allow him to select an audio device for playback. –  Chrono May 13 '13 at 20:54

One other option to check... I use a IBM/Lenovo laptop, and I was getting a similar problem on my system where certain apps would play in the headphones and others would go through the built in speakers; even if the headphones were plugged in. The internal sound card in my laptop is provided by Conexant. I found that outside of the standard Microsoft "Audio" control panel, Conexant also provided another control panel called "Smart Audio" that I hadn't noticed before. Upon reviewing that control panel, there was a "Audio Director" setting labeled as "Classic" or "Multi-Stream". Mine was set to Multi-Stream, so it allowed some audio to go to the internal speakers, and some to my headphones, but when I set it back to Classic, all the audio moved to the headphones when they are present. I think that's what your looking for. You might see if HP has a similar software driver that is allowing Multi-Stream audio on your system. Hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.