Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have zsh with oh-my-zsh, I added an alias to color the make output using

alias make="colourify make"

but when I use it, make autocompletion does not work anymore. If I use unalias make, the make autocompletion works anew,

how can I force the make autocompletion to work on the alias?

share|improve this question
up vote 0 down vote accepted

As a work-around, try using a shell function instead:

make () {
    colourify make "$@"
}

The same completions will apply to your function as to the "real" make command, but your function will then take care of calling colourify with the given options.

share|improve this answer
    
This worked, but I had to replace the alias to colourify itself by a function:) – oulipo May 13 '13 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .