Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I desactivated the antivirus, firewall, went to internet options privacy added to the allow list for SITES and nothing happened.

Windows defender its already OFF. Checked using HIDEMYASS and could access to the website so it means that its not the browser. I already tried with IE (bad words) but same result = nothing.

I checked the host file but it doesn't seem to have some IP added :S

What else can I try?

share|improve this question
2  
At home or at work? There may be a policy on the router, domain, external firewall, etc. preventing this. –  Kruug May 13 '13 at 19:55
    
What website? Seems to be a domain and or network issue rather then Operating system. –  Ryan E May 13 '13 at 19:58
    
Checked already disabling firewall, not using router, im at home –  Windows Mid Range User May 13 '13 at 20:01
    
I was able to surf that website with the same IP that I'm using now... –  Windows Mid Range User May 13 '13 at 20:02
    
Clear your cache and try an alternative dns server. –  Scandalist May 13 '13 at 21:34

1 Answer 1

I need to know what error message it is giving you when you try to access the site. Have you tried running the windows network troubleshooter? All you have to do is right-click on the bottom right of the screen where it shows your internet status and then select troubleshoot problems. This can resolve a lot of issues, at least give you an idea of whats going, or an error code you can post here and Google.

However, a lot of times this can be the result of the clock on your computer being off. Such as being set to a date in the past/future. When this happens it looks to you computer that the security certificate that the website is offering is invalid.

share|improve this answer
    
I got my clock with bad time, but now I sync I will reboot and see if it works properly now... if works I will Kxll you! –  Windows Mid Range User May 13 '13 at 20:05
    
Nothing changed same... and the clock its set with internet with the right time... –  Windows Mid Range User May 13 '13 at 20:11
    
Oops! Google Chrome could not connect to steamgifts.com Try reloading: steamgifts.­com Additional suggestions: Access a cached copy of steamgifts.­com Search on Google: Checked the website and its UP –  Windows Mid Range User May 13 '13 at 20:13
    
you may have to go into the bios of your computer and change the time there –  Chrono May 13 '13 at 20:14
1  
Aren't those times Sync with bios and windows? –  Windows Mid Range User May 13 '13 at 20:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.