Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using Midori for a while now, and got tired of flash not working so tried to install it.

I checked the checkbox "Install flash and other 3rd party proprietary stuff" button when I installed my distro, so have flashplugin-installer installed. I am using Elementary OS 0.2 Beta 2, based on ubuntu 12.04 with the 3.5 kernel from 12.10.

These are the things I have tried yet:

  • Re-installed flashplugin-installer via both apt-get and software centre
  • Downloaded the .tar.gz flash directory from adobe, and put libflashplayer.so in both /lib/mozilla/plugins and in /home/user/.config/mozilla/plugins.
  • added 'export MOZ_PLUGIN_PATH="/usr/lib/mozilla/plugins"' to my .bashrc
  • added the line "enable-plugins=true" to the midori config
  • On the midori faq they tell you to "nspluginwrapper -v -a -n -i", which returns "ERROR: libssl3.so: cannot open sharet object file: no such file or directory". Have searched for this error and not found a fix

I have followed the steps on these threads

  1. http://ubuntuforums.org/showthread.php?t=917636
  2. http://puppylinux.info/topic/midori-browser-Flash not working in Midoriwhere-to-install-flashplayer
  3. http://midoribrowser.org/faqs/
share|improve this question
    
Only so you guys know, i still watch this question – Johan Bjäreholt Jun 19 '13 at 16:43
up vote 1 down vote accepted

I tried this simple trick and it worked for me. Check the path in your system accordingly

64-bit system

cp /usr/lib64/mozilla/plugins/libflashplayer.so /usr/lib64/midori/.

32-bit system

cp /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/midori/.

Close Midori(if open) and open it again..flash player will work..

share|improve this answer

I had so many troubles with flash in firefox & Midori. Finally, I found this bash script that fixed EVERYTHING :) It was also very user friendly.

  1. Download this small bash script: freshplayer_maintainer.sh
  2. Ctrl + Alt + t to open the terminal
  3. Go to the save location cd /where/I/saved/the/file/
  4. Run bash on the file bash freshplayer_maintainer.sh
  5. Once running, select option 1, to install freshplayerplugin.
  6. When prompted, choose to install system wide. DONE!
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .