Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like to study a lot of code from various sources from around the internet, and a big part of that involves downloading and opening the files to view the source code.

Now every time I try to open these files it gives me a prompt to make sure that the file is from a valid source and that I trust it to run.

There are many answers on this site, that deal with this issue on the following OS; Vista, XP and 7, but I couldn't find one for 8, and I could not get any of the others to work!

Could someone please tell me how to disable this very annoying feature for someone like myself?

share|improve this question
3  
It's flagging the file as external due to your Zone settings in IE. This information is stored in an [Alternate Data Stream][1] on the file you downloaded. You can fix this by clicking Unblock in properties on the file, but the way I like to do it is running: type filename > newfilename. Del filename. Rename newfilename filename. Voila - no more alternate data stream. If that's too extreme you can use streams.exe ([download][2]) to remove alternate data streams. [1]: support.microsoft.com/kb/105763 [2]: technet.microsoft.com/en-us/sysinternals/bb897440.aspx –  Mark Allen May 13 '13 at 23:18
2  
Also, what part of the Windows 7 solution didn't work for Windows 8? –  Mark Allen May 13 '13 at 23:18
1  
@MarkAllen you could also use the powershell command described on blogs.technet.com/b/askcore/archive/2013/03/24/… to remove the ntfs alternate data stream "Zone.Identifier" with the command remove-item -path "somefile.zip" -stream "Zone.Identifier" and that would work too. –  BeowulfNode42 Aug 29 '14 at 6:15
    
@BeowulfNode42 I like it! –  Mark Allen Aug 29 '14 at 23:52

6 Answers 6

I had a very similar problem on my brand new Windows 8 laptop. The desktop icons (.lnk)'s gave the same "open file security warning". Don't know why or what happened but what a pain. I finally found a solution, at least for the desktop icons doing it. I didn't want to fix it with changes to IE10 settings, like some suggest, because that just seemed risky.

This worked for me:

  1. Press Windows button + X to open the Tools menu
  2. Select: Command Prompt (admin) to open the black DOS window with C:\Windows\system32\>
  3. Enter

    cd \Users
    

    The display now says C:\Users>

  4. Enter (replacing "YourName" with your username)

    cd YourName 
    

    The display now says C:\Users\YourName>

  5. Enter

    cd Favorites 
    

    The display now says C:\Users\YourName\Favorites>

  6. Enter

    cd Desktop 
    

    The display now says C:\Users\YourName\Favorites\Desktop>

  7. Type and enter:

    C:\Users\YourName\Favorites\Desktop>ICACLS *.LNK /L /SETINTEGRITYLEVEL MED
    

All the links on your desktop should come up as:

processed file: whatever.lnk
successfully processed 10 files; Failed processed 0 files.

Sorry for the long hand on the DOS commands, I remember them from back in the day but, this is laid out for anyone to easily follow.

share|improve this answer
    
Tried this first, but it made no difference. Setting SEE_MASK_NOZONECHECKS (see below) did. –  Umber Ferrule Jan 22 at 14:23

Add a system environmental variable SEE_MASK_NOZONECHECKS and set the value to 1.

Make sure it's a system level variable or it will go away on reboot.

Use of Environment Variable in Windows 8

share|improve this answer
    
"Make sure..": You mean the right thing, but it does not help the newbe: You can also create it for the current user, often this is enough, it depends on what you want (see below). What you mean, is that the change should be permanent, what is not the case, if you use "set" command for example. –  Philm Jun 29 at 7:18
@setx see_mask_nozonechecks 1

typing it in the command prompt, or executing inside a batch file will create the environmental variable that Dasun mentioned, for the current user

share|improve this answer
    
+1 It works, this is most important. To explain, when to use which command, some info is missing. I will try to extend the tip in an own answer. –  Philm Jun 29 at 7:20

You should be able to resolve this by seting up trusted sites properly?

Other wise, try this.

Close internet explorer
Open up a cmd prompt
cd "\Program Files\Internet Explorer"
set SEE_MASK_NOZONECHECKS=1
iexplore

This allows the file to open directly from Internet Explorer, however the file on disk will still be 'blocked'.

One other solution is to open the files directly from your text reader, i.e Notepad++. It is explorer that is enforcing the warning.

See: "This file came from another computer..." - how can I unblock all the files in a folder without having to unblock them individually?

share|improve this answer

Changing the environment variable SEE_MASK_NOZONECHECKS as mentioned by other answers is the way to go. I will explain here more details. It has advantages because it does not only take away the "downloaded by internet" flag away as the "ICACLS myfiles.* /L /SETINTEGRITYLEVEL MED" command or similar methods, but also work, if files are started from an unsafe network drive like UNC paths.

But the interesting point is, how to set this environment variable:

  1. If you need this only for setup, which should run unattendedly on foreign machines, it would be unsafe to change this variable permanently. But you can change it temporarily in your process before you start the setup, e.g. in a batch file with "SET". By default the environment is inherited to the child processes, for example started in the same batch.

  2. The environment is user specific. If the user has no admin rights or the behaviour should be changed only for one user, take the command already mentioned:

    setx see_mask_nozonechecks 1

  3. If you want to change the behaviour not only permanently, but also for all users (whole machine), add a /m parameter to the command line:

    setx see_mask_nozonechecks 1 /m

One more remark: With Windows Server 2012 R2 I do not get the warning when accessing a remote (non-domain) drive like a VMWare shared drive at all. I have needed this trick only under Windows Server 2008 R2 and before.

share|improve this answer

Simple PowerShell command to fix such files:

Unblock-File -Path

This essentially removes the ADS which IE slaps while downloading from other sources. Also helpful is the following script if you wish to search and remove all blocked files download in a folder:

#Search and unblock all files recursively
$p="C:\Download Folder\*"

$c=gci -Path $p -Recurse | gi -Stream "Zone.Identifier" -ErrorAction SilentlyContinue
foreach ($f in $c)
    {Unblock-File $f.FileName}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.