Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to modify the hosts file in Chrome OS?

­­/etc/hosts

The file is read only, so trying to modify it using sudo vim does not work.

I have read that disabling root filesystem verification would make editing the hosts file possible, but would also make you loose Chrome OS auto update.

­ sudo /usr/share/vboot/bin/make_dev_ssd.sh --remove_rootfs_verification --partitions 2

Is there any way to modify the hosts file without loosing automatic updates?

Thanks for your help.

EDIT: Just to specify, I am using an Acer C7 Chromebook with developer mode enable.

share|improve this question
    
You should be able to modify the permissions of the file by using sudo cmod have you tried that? –  Ramhound May 14 '13 at 11:46
    
I have tried sudo chmod, does not work and instead outputs chmod: changing permissions of ‘hosts’: Read-only file system. –  Bricknix May 14 '13 at 21:03
    
You will have to use the command you found to do it then. –  Ramhound May 14 '13 at 23:09

4 Answers 4

There are two options available:

1.) Edit the hosts file from a Developer Chromebook:

sudo /usr/share/vboot/bin/make_dev_ssd.sh --remove_rootfs_verification --partitions 2

You will lose changes to the hosts file when ChromeOS does update again. Updates can be disabled by creating the file /mnt/stateful_partition/etc/lsb-release that contains the following 2 lines:

CHROMEOS_RELEASE_VERSION=9999.9999.9999.9999
GOOGLE_RELEASE=9999.9999.9999.9999

2.) Using a proxy-extension

share|improve this answer

Unfortunately, I do not know either how to modify the host file without disabling the auto-update functionality, but depending on what you want to use that host file for, you could try installing a Chrome extension that has similar functionality as the host file.

For instance, there is Block Site for making your own list of sites you want to block. There is AdBlock Plus for blocking ads. And there is Rescue Time Dashboard for keeping track of which sites you spend most of your time on.

share|improve this answer

did you try remounting the partition as rw? I don't have a chromebook, but have had this issue on other platforms...

mount / -o remount, rw

hth

share|improve this answer

If you want to change your hosts file so you can point back to 127.0.0.1 then can I suggest http://readme.localtest.me/.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.