Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a sublime-project like this:

{
   "folders":
   [
      {
         "path": ".",
         "folder_exclude_patterns": ["_doc", "cache", "logs", "_release"],
         "file_exclude_patterns": ["*.sublime-workspace"]
      }
   ]
}

In particular I'm excluding _doc, _release, etc. from the project. They seem to be excluded fine since they don't show up in the side bar. However, when I do a search, ST also searches in these folders and returns all kind of unrelated results.

For instance, if I do this search:

I get results such as this, even though the file is in the _doc folder, which has been excluded:

Any idea how to avoid this?

share|improve this question
    
Did you try adding those folders to your User settings instead of just your project settings? –  d_rail May 17 '13 at 20:41

1 Answer 1

up vote 3 down vote accepted
+200

You should try to use <project> or <open folders> instead of dot (.) in Where: field.

share|improve this answer
1  
Thank you so much for this answer, I've asked everywhere but it seems not many people know this. It changed a lot the way I work with ST2 - now instead of waiting 1 minute for the search to complete and get a bunch of unrelated results, it takes 2 seconds with proper results (using <project>). I will award the bounty tomorrow when the system allows me to do so. Thanks again for this! –  this.lau_ Jun 1 '13 at 7:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.