Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not able to see the sched_compat_yield entry under /proc/sys/kernel/. How to enable this propery in the kernel (so that I can tweak it for some debugging purpose) ?

Currently Available Entries:

root@test ~ >ls /proc/sys/kernel/sched_*
/proc/sys/kernel/sched_child_runs_first
/proc/sys/kernel/sched_latency_ns
/proc/sys/kernel/sched_migration_cost
/proc/sys/kernel/sched_min_granularity_ns
/proc/sys/kernel/sched_nr_migrate
/proc/sys/kernel/sched_rt_period_us
/proc/sys/kernel/sched_rt_runtime_us
/proc/sys/kernel/sched_shares_window
/proc/sys/kernel/sched_time_avg
/proc/sys/kernel/sched_tunable_scaling
/proc/sys/kernel/sched_wakeup_granularity_ns

I am using "Linux 3.3.0 #19 PREEMPT Wed May 8 14:38:18 IST 2013 armv5tejl GNU/Linux".

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You won't be able to enable it because it doesn't exist any more - it was removed over two years ago by this commit which is included in 2.6.39 and later kernels.

If you're interested in how you can figure things like that out yourself then the answer is that I used git log -S sched_compat_yield in a kernel checkout to look for commits which introduce or remove that string from the code.

share|improve this answer
    
thanks a lot for introducing me to "git log -S" –  Lunar Mushrooms May 14 '13 at 14:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.