Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About half an hour ago Windows informed me it was trying to install software for an "Unknown Device". However, it failed. Using the Control Panel I checked the device's properties, and discovered that it was reported to be occupying a USB port which had nothing currently plugged into it. The device then disappeared from the Devices and Printers menu.

I'm running Windows 7, and I'm curious to know what the possible causes of this are. It seems slightly odd and suspicious that Windows would randomly report a new device for no reason.

share|improve this question

1 Answer 1

Open the eventlog and filter for Event ID 20001. This event shows installation of new devices. Check the details tab for the DeviceInstanceID and look into a PCIDatabase which device this is.

share|improve this answer
    
I got USB\VID_0000&PID_0000. It seems likely that zeroed IDs are the result of some sort of error. –  otvysvyz May 14 '13 at 15:04
    
can you see other events at this time? –  magicandre1981 May 14 '13 at 17:43
    
Looking at all events from the ten-minute window it occurred in, there's a PnPDeviceProblemCode (Event ID 1001) Response: Not available a second later. I can't see anything else that looks relevant to me. –  otvysvyz May 14 '13 at 18:07
    
can you post the details of this event? –  magicandre1981 May 15 '13 at 3:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.