Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It is always a really big pain for me, as the longer I have Chrome open, the slower the Omnibox becomes, such that it will take half a second for it to register my keystroke.

Everything else runs extremely smooth. I can watch 2 HD YouTube videos and have 30 tabs open and browse with no lag at all.

What I have been doing so far is simply closing and starting up Chrome again, which fixes the slow omnibox until it starts slowing down again. I've noticed that even if I only have one tab open, this will still happen.

share|improve this question
2  
Have you already tried to clean your browser history and deactivate the Omnibox autocomplete feature and Instant? Do you report the same issue using Incognito Mode? – pietrodn May 14 '13 at 16:54
    
I've tried cleaning my browser history, cache, cookies etc. - still the same. Deactivating the instant search does not help, nor is there any difference in incognito mode. It's just that it slows down the longer Chrome is open. Reinstalling does not help either. – Mastergalen May 16 '13 at 14:34
    
Maybe Chrome eats too much RAM over time, and restarting it helps freeing some. Can you track down the RAM usage? Also try running Chrome in a different user account on your system, if you can. – pietrodn May 16 '13 at 15:36
    
I don't think it is a RAM issue. In chrome://memory-redirect/, when the omnibox was slow memory usage was 2,083,924k. Just after I restarted Chrome with the same tabs open etc. memory usage was 1,749,917k. – Mastergalen May 16 '13 at 16:20

For most users this error is caused by the chrome.exe file being set to run in Windows 7 compatibility mode. Disable the compatibility mode and it should fix the problem.

If it doesn't work or you want to read more about it this is a link to the issue:

https://code.google.com/p/chromium/issues/detail?id=178705

share|improve this answer

This is a chrome/chromium bug. In debian(xfce4), chrome/chromium>=45 will cause the omnibox typing really slow. Deleting cache could temporarily rescue this, but this bug will happen again when the browsing history increases. Downgrade back to version 44 can solve this. Waiting for chromium fix in the furture(still exists in google-chrome-stable_46.0.2490.71-1)

share|improve this answer
    
If it is a bug then a helpful answer would have a link to the confirmed bug report. – Ramhound Oct 14 '15 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.