Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 4 primary partitions on my hard disk with MBR partition table. I don't use "System Reserved" aka "separate boot" partition. So the first partition is labelled "System boot active primary" .

If i install windows 7 from dvd drive, I get the drive letters in a normal way as below

  • partition 1 = C (windows7 installation)
  • partition 2 = D
  • partition 3 = E
  • partition 4 = F
  • dvd drive = G

This is quite normal and i wish the drive letters in this way.

But when I install windows 7 from USB drive, the drive letters go weird like this.

  • partition 1 = C (windows7 installation)
  • USB drive = D
  • partition 2 = E
  • partition 3 = F
  • partition 4 = G
  • dvd drive = H

My dvd drive is not working now and i have to install from USB. How can i get rid of this weird drive letter problem when installing windows 7 from USB? I don't like changing the drive letters from disk management after installing windows. Is there a way to prevent this crazy drive letter assign before installing windows.

share|improve this question

closed as not a real question by Ƭᴇcʜιᴇ007, Brad Patton, Mokubai, Dave M, 8088 May 16 '13 at 16:03

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
What's the problem with changing the drive letters from disk management ? –  matzone May 14 '13 at 17:03
    
I had a bad impression on changing the drive letter. Previously while using windows xp I somehow changed and messed up the drive letters and it resulted in deleting the wrong partition during windows xp setup. –  bharat May 14 '13 at 17:41
1  
Each drive have a label name .. name it SYSTEM or DATA or BACKUP .. I think you wont messed up with those name .. So, I think changing the drive letters from disk management is the easiest way for this .. –  matzone May 14 '13 at 17:45
1  
Changing the letters through Disk Management is the only way to do what you want since you only have a single hdd with 4 partitions. –  Ramhound May 14 '13 at 18:31
    
@Ramhound Is there an option if I have two hdd's. –  bharat May 14 '13 at 19:23

1 Answer 1

I found a way to get rid of this.

The solution is to create USB bootable media formatted with FAT32 filesystem

I was using "Windows7-USB/DVD-tool" to create bootable usb. This tool formats the flash drive with NTFS filesystem and sets it to active primary partition. And during windows7 installation it first seems to give drive letters to "active ntfs" partitions. Hence the usb drive gets letter D:

Now i created the usb drive with FAT32 filesystem and it didn't give the letter D: to usb drive. Nice workaround.

This is how I created windows 7 usb bootable media formatted with fat32.

  • insert usb stick (atleast 4GB).
  • open command prompt and enter diskpart
  • type list disk and note the disk number of the usb stick. (say it is #)
  • type select disk # and enter.
  • type clean and enter. This will delete the contents of usb stick. So make sure you have backed up everything.
  • type create partition primary. It creates a raw partition.
  • type list partition to check if the partition is successfully created.
  • type select partition 1 to select the partition of usb stick.
  • type format fs=fat32 quick to format the usb partition.
  • type active to make it bootable.
  • then copy the contents of installation dvd to the usb stick .
  • That's it. Restart pc and select boot device as usb-hdd .
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.