Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two major issue with setting up a web server using my dlink DIR-600L router.

Issue 1:

I run a WebPy server on port 8080. But the DDNS service providers (like dlinkddns.com or dyndns.org) only allows port 80. I can run the server in port 80 with sudo command. But my server become vulnerable if i give root access. So I tried port forwarding in the router and server. But no use. I don't know if I done that correctly.

Issue 2:

Even though the server runs on port 80, I can access my site from my local machines only using registered domain names ( say, nikz.dyndns.org). No one on internet cannot load this site even when its totally up. As I observed server log, the request from other clients never reached my server.

I need to run this server on port 8080 and i need to access this site from internet. How can I do it? any idea?

share|improve this question

migrated from serverfault.com May 14 '13 at 20:59

This question came from our site for professional system and network administrators.

    
@j0k Do you know any solutions for this? –  nuke1010 May 14 '13 at 18:56
    
Better suited for Superuser, this is consumer grade hardware. –  Dan May 14 '13 at 19:04
    
I registered "nikz.dyndns.org". When my router is on, the site go up. But it is only available inside my local network. Any idea why i can't access it from internet outside my LAN? –  nuke1010 May 14 '13 at 19:07

2 Answers 2

I don't really know much and you may have already tried the below but it sounds like its most likely a dns issue or maybe a server firewall issue. I would probably try to test each component separately.

Test nslookup both internally and externally to see if it resolves to the correct wan address. It might be resolving to a private ip address instead. If the external nslookup is not showing your wan ip address then there is a problem with the dyndns setup.

Test to make sure the webserver can accept connections by trying to connect to it locally. It sounds like that part is already working but just to double check that your server's iptables rules is correct.

You can also put a simple to set up web server on a windows machine with the firewall in that machine set to off just to see if connections get through. If it works from the outside then you would know your router configuration is correct and the dyndns is working.

share|improve this answer
    
I already checked the last 2 cases and found no issues with firewall or web server. I know the command 'nslookup'. But as I haven't done the first test ever before, can you please tell me how to do the nslookup, externally and internally? –  nuke1010 May 15 '13 at 14:00

It's mostly because your home network blocks port 8080. You have no choice but to sign a new line or ask them help open port 8080.

share|improve this answer
    
How did you determine that his ISP was blocking port 8080 based on the information provided? I'd lean toward their router providing a non-routing DHCP address and OP trying to register the non-routing IP address with dyndns.org. –  Jason Aller May 27 at 1:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.