Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed the directions here:

NTFS-3G via Homebrew installation

If you have [Homebrew][5], installing NTFS support is as easy as running the following in a terminal:

brew install ntfs-3g

Then, follow the instructions on the screen. Homebrew will tell you how to replace the default OS X automounter so external NTFS drives are mounted using the new driver. Those are a couple of commands you need to run through your terminal.

And it worked perfectly at first, but a couple days later now and when I insert a USB drive that worked before, it is mounting as read-only.

How can I get NTFS-3g working again? I tried reinstalling the homebrew, but it stated that it was already installed and did nothing. Should I uninstall and reinstall, if so, how do you uninstall a homebrew item?

share|improve this question
    
You can try brew remove ntfs-3g and then install again. No need to completely remove Homebrew though. Make sure you follow the instructions where you have to copy a file over—this is needed to have OS X automatically mount drives in write-mode. – slhck May 15 '13 at 7:13
    
Yeah, I don't have the instructions anymore, perhaps that would be sufficient, but lacking that, I will remove and reinstall to get the instructions again. – WilliamKF May 15 '13 at 17:10
up vote 4 down vote accepted

NTFS-3G asks you to replace /sbin/mount_ntfs with their own version. If it stops working, then probably is because an OS X update replaced that file.

To fix this, you must do the following:

  1. Rename the mount_ntfs command provided by OS X:

    sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original

  2. Make sure the mount_ntfs command provided by NTFS-3G is used:

    sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs

share|improve this answer
    
Can you please explain what these command do? – Cfinley Aug 7 '14 at 13:55
    
I've edited the answer to provide a little more detail – tvs Aug 7 '14 at 23:51
    
Thanks for updating. – Cfinley Aug 7 '14 at 23:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .