Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For two years now my laptop's graphics card has not been correctly identifying its current OpenGL version. It says it is running OpenGL version 1.1. However, after re-installing the video card drivers (multiple times) my system still incorrectly reports an older OpenGL version. My laptop is reporting that it is running OpenGL 1.1, but the video card (AMD Mobility Radeon HD 2300) and the drivers (most updated Catalyst Suite drivers), report that the card should support OpenGL 4.2.

How can I either update my OpenGL version, or get my system to correctly run a newer version of OpenGL?

share|improve this question
add comment

2 Answers

According to this thread you will need to download the legacy Catalyst 10.2 Drivers (32 bit) and use the mobility loader instead of the drivers provided by the manufacturer and it may make the laptop work.

share|improve this answer
add comment

Are you absolutely sure your computer can run Minecraft? Your graphics card is a bit outdated. Take a look here; you'll find other users experiencing the same problem. As far as I know there is no way to update OpenGL without obtaining the latest video card drivers. Depending on your OS, there may be an option to lower the hardware acceleration in the Control Panel. Set the slider 3 notches from the left and save the changes. It may or may not work in all cases, but it's worth a shot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.