Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Setup: Cygwin on Windows 8 64bit. UAC enabled.

Scenario: I run cygwin without administrator privilege. I go to a directory and create a new file. Turns out I don't have write access to this directory. Cygwin does not write error message and create the file anyways. I can use this cygwin session to access the file without issues.

However, when I use windows' file explorer, I can't find the file. If I run Cygwin as administrator and go to the same directory, the file is not there. The file shows up only if I run Cygwin without admin privilege. I can't find any documentation of this behavior anywhere.

Where does cygwin put the file? Why can't I see it if I run with administrator privilege?


share|improve this question

migrated from May 15 '13 at 19:13

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 0 down vote accepted

That's Windows' Virtual File Store in action, as introduced with Vista. It redirects unauthorized writes by limited users to C:\Users\Username\AppData\Local\VirtualStore. More on this on MSDN.

share|improve this answer
This is it. Thanks! –  hpoer May 16 '13 at 19:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.