Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm RDP'ing into a Win2K3 machine from a WinXP machine, and I cannot stand the low screen resolution I get on the Win2K3 box. Text is too large and the graphics/colors aren't very smooth. How do I improve this?

If I right-click on the desktop of the remote machine and go to Properties -> Settings, I see that the screen resolution is set to 1280x1024 (should be okay, I would think), and the color quality is Medium (16 bit) (not optimal) and I don't have the option to change either setting (because they're set in the .rdp file for the session, right?).

If I move over to the Appearance tab, I see that font size is set to Normal, with no option to make it smaller.

The thing is, these settings are close to what I have on the XP machine I'm RDP'ing in from. The only difference (in those settings) is the color quality, which is 32 bit.

Any ideas on how I can improve the situation?

Other tidbits:

  • The graphics card on the Win2K3 machine is ATI ES1000. I think I have the latest drivers for it.
  • I'm running VMware Workstation on the Win2K3 machine, and if I create a Win2K3 VM and RDP into it from the XP machine, the resolution is just fine.
share|improve this question

4 Answers 4

up vote 5 down vote accepted

The maximum is actually 24-bit, but it's disabled by default. It's nothing to do with the graphics card. You can enable it by following the brief instructions listed here :

http://www.compdigitec.com/labs/2009/03/07/enabling-24-bit-colour-rdp-in-windows-2003/

share|improve this answer
    
As CodeByMoonlight has mentioned, Windows Server disables true color (24-bit and higher) by default. This is done to conserve resources and network bandwidth on a Terminal Server, which may typically have many users using Remote Desktop/Terminal Server Client simultaneously. –  rob Oct 23 '09 at 21:40
    
Well, this has not fixed everything -- the fonts are still large and not very smooth, and it's not as nice looking as the Win2K3 VM's that I RDP into -- but it's certainly an improvement that I wouldn't have figured out on my own. –  Jeff Oct 23 '09 at 23:03
    
Link is broken. –  cbp Jul 23 '13 at 0:48

Before you connect to your Windows Server 2003 machine, you should set the target machine resolution.

Open RDC, section "Options" -> go to "Display" tab, select a resolution you want (note the resolution can only be smaller or equal to your XP machine.

alt text

If the settings are alread to "full" and you think that the image quality is still not good enough, move to "Experience" tab and select the appropriate connection (Modem is poor, LAN is the best).

share|improve this answer
    
My Win2K3 machine seems to kick me down to 32 bit, and I was already at the correct screen size. It's the appearance that's messed up. Video card/driver issue? –  Jeff Oct 23 '09 at 20:21

Before you actually connect

  • click Options to expend options tabs
  • select display tab and choose desired resolution and color depth
  • click Connect
share|improve this answer
    
I see the little note that says that the remote machine may override that setting. That appears to be happening to me, because I always get kicked down to 16 bit. So does that mean it's my video card on the Win2K3 machine? –  Jeff Oct 23 '09 at 19:54

You change this in the options before you connect.

If you already have full size, go one step back and it will sometimes go to a larger size than what the full size was set to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.