Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently noticed that there is a file (a document) in my Google Drive that failed to sync. I didn't need it, so I deleted it.

Now, in my computers GD folder there is a directory with the name of that document. And it can not be deleted, renamed, etc.

I can open it, create files (and directories) inside of it, open files inside of it, modify/save those files, and delete them.

But if I delete or rename the directory its self, I get an error:

Could not find this item

This is no longer located in C:[path to file].

Verify the item's location and try again.

The file has been deleted in Drive, and my trash has been cleared. It should be gone, but it still shows up! I even tried removing it with alternate file managers, which also show that it exists, but can not delete it (similar error messages). And I attempted to do it with command prompt, but:

The system cannot find the file specified.

This is very annoying, and Drive still calls those files unsyncable:

Download Error - You only have permissions to view this file, so your

changes can not be synced.

Permissions should(?) be irrelevant, as I created the file, and it was never shared.

For reference: Running Windows 8 x64

Interesting edit:

If I create a folder by that name in GD, it will show up in windows as if I had two directories of the same name. I can hit delete on either, but the one with the newer time-stamp will be deleted (even if I attempted to delete the older one). And the other (older) will remain impossible to delete.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Open command prompt, navigate to Google Drive folder, Use

dir /x  

to view the 8.3 format filenames and use that to delete the folder in question

For example, if the 8.3 format name of the folder in question is NAME~1:

del NAME~1

Got my answer from here. Excerpts from that answer as to why this happens:

A filename conflict: They are rare (they are not supposed to happen), but certain circumstances (like race-conditions) can lead to them occurring. In this case, the best way to deal with them is the same as when dealing with files with invalid filenames (like those with illegal characters in them or spaces in the DOS days).

share|improve this answer
    
That worked. The "8.3 format" thing did the trick. Any idea why/how this would occur? –  zeel May 16 '13 at 14:38
    
@zeel edited the answer with source and reason as to why this happens –  Cybertox May 16 '13 at 18:18

Directories in Google Drive are basically what used to be tags. Can you delete the tag/folder from the Google Drive interface?

update:

Sounds like an error in the OS if the file is no longer in Drive. To be sure, I would uninstall Drive (the files will still be there), boot into safe mode without network and delete the offending file (should work), boot back in in Windows and re-install Drive and sync it with the existing folder. If the folder appears again, this is caused by Drive. Otherwise, problem fixed. If safe mode does not work, boot a USB Linux variant and delete it from there.

share|improve this answer
    
That is not an answer, please use the comments feature. But on topic: "yes" - You can do that, but GD doesn't show this file at all. Windows dose. –  zeel May 16 '13 at 6:31
    
You didn't mention anywhere that GD did not show the label. Because it is a label (or recently, a folder), not a file as far as Google is concerned, if it's a folder in your file system. Drop the attitude. Try booting safe mode without Google Drive enabled and remove it from there. –  bigbadonk420 May 16 '13 at 6:35
    
Drive actually uses directories(/folders) now, not labels. However the item in question started as a file named "Values" (it was a Google document, containing text). There is now a directory in windows called "Values" (there was never a GD folder by this name, only a document). And that directory is not synced to drive (because of the mentioned error), and it is evading my attempts to delete it. –  zeel May 16 '13 at 6:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.