Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to remotely access a machine on Virtual Box, which is on a terminal server, but I don't want to have to log onto the terminal server first.

I have enabled the Remote Display Settings in Virtual Box Manager.

Virtual Box Remote Display Settings

The firewall on the Virtual Machine is not blocking access, as I can ping the machine from my local machine, and from the terminal server.

The issue is when I try to RDP into the machine, it asks me for the username and password, which I give the correct information, but says it fails to connect.

Is this just my issue, or am I doing something wrong?

share|improve this question
add comment

2 Answers

I assume that your virtualbox has not a own IP address, but rather some nat or host-only network.

So when you RDP to your TSE, it's the TSE login you see.

I would do the following:

  • Make the VM use a bridged network and assign it it's own IP address
  • In Virtualbox don't enable remote display
  • In the guest OS, activate the RDP access

This way you can directly authenticate against the guest OS

share|improve this answer
    
Thank you for your answer, I will give that a go. –  Kevdog777 May 17 '13 at 7:46
add comment
up vote 0 down vote accepted

I have managed to log in using the computer's IP address, then I was using a UK keyboard and typing the wrong password in. The keyboard on the machine is a US keyboard, so the password is totally different. Like the @ symbol is on the right side of the keyboard, etc.

Thank you for looking at the question and trying to help me sort it out.

share|improve this answer
    
The obvious "way" to check would be checking the default keyboard/locale settings of the system running in the VM. Looks likes this is using default US... –  André Schild May 21 '13 at 6:16
    
@AndréSchild yes it is. I didn't realise it before, so my colleague tried it and worked first time, then he told me what he did. :) –  Kevdog777 May 21 '13 at 8:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.