Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a query on SQL. Typically I can easily copy and paste the results from the query into Excel and it preserves the columns, rows etc.

However, in this case I'm selecting a bunch of emails and the bodies of those emails are html formatted. Every time I try and paste into Excel 2010, it completely messes it up since it's trying to be 'helpful' by parsing the html and converting img tags to images and table cells to Excel cells etc.

Is there some way I can have Excel be dumb and just paste my text without trying to figure out something clever to do with it?

I've tried using Paste Special. I've tried prepending a single quote to the start of the html body (someone said that tells Excel to treat the field as text and not parse it). I tried putting pipes | between each column, saving it to a text file and then importing the text file. No matter what I do, Excel keeps messing with the html.

Does anyone know how to paste html into Excel as just plain 'ol dumb text?

share|improve this question
    
Try unchecking all the delimiter options in the Data / Text-to-Columns dialogue box. – chuff May 17 '13 at 1:00
    
If you mean in the wizard, already tried that. Besides, it's clearly not a delimiter issue. It's very obviously parsing the html. And As i said, it'll display <img> tags as the actual image. splitting up table cells into excel cells. So it's definitely trying to do something clever with the html. I just want it to paste everything as text and not try and do anything 'helpful' for me. – merk May 18 '13 at 1:37
    
Did you also check the 'Text' option in Step 3 of the Text Import Wizard? – Jerry May 22 '13 at 15:36
    
Yes i did, had no effect – merk May 23 '13 at 19:03
1  
Did you ever find a solution for this? I am trying to do this exact thing now! – franglais Jun 3 '14 at 11:54

I figured it out!!!!

Try DOUBLE CLICKING in the cell to which you want to paste (rather than simply selecting the cell with a single click). Your paste option should then switch to text and NOT parse the text data.

share|improve this answer
2  
this was a while ago - i'll try this next time although if i remember correctly this wouldn't have been much help for me since i was pasting multiple records. Having to paste each cell one at a time would have been very unpractical – merk Aug 14 '14 at 22:18

User [daverunt] on Mr. Excel Forums gave this answer.

It may not be applicable in all situations, because you have to save it to a ".txt" file, but it was the quickest way I could get around the problem when I had the same issue as in the original post. Mainly, in one step, it will prevent the HTML-interpretation of all your lines of text.

I think the best way is to save it in a text file.
In Excel select File Open.
Select Delimited then next
Un-tick all delimiter selections then Next
Text then Finish

share|improve this answer
    
Thanks for the edits, G-Man. And by the way ... superb avatar. – Mark Goldfain May 3 '15 at 3:29

Select the HTML, paste as Keep Text Only in to a new Word document, then Select All, Copy. Then when you right-click in Excel you have a Match Destination Formatting option, which is not available through the expected route. Slightly less tedious than saving as a separate file, but still a workaround that you shouldn't have to do.

share|improve this answer

Note a shortcut to do this is to copy the marked up text, select the cell, then use the F2 keyboard shortcut. This has the same effect as double clicking in the cell or clicking in the text entry bar at the top of the screen, it will bring the cursor into the cell and allow you to edit the text.

This is a standard windows shortcut to edit whatever is selected. It also works for renaming files in explorer.

share|improve this answer
    
The question is looking for a solution where the html links would not be parsed and be clickable. It is not on how to edit a link – Prasanna Apr 15 at 10:42

paste it in google spreadsheet, then again copy and paste it in your excel sheet. It will show as code/text not html value

share|improve this answer
    
There is a feature within Excel where you can indicate the paste operation should just be plain text. Using Google Spreadsheets is an extra step that isn't needed. – Ramhound 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .