Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Kali Linux from a mini ISO network install on VirtualBox. I then installed xfce and ran startx on root account.

apt-get install xfce4
apt-get install xfce4-goodies
startx

xfce starts perfectly. I logged out from xfce. I then created a new user:

useradd everyone
passwd *******
mkdir /home/everyone
chown everyone:users /home/everyone

I log in with new user and startx:

exit
login: everyone
startx

When I run startx as another user than root, the screen blinks and goes back to the command line again. I tried XDM but when I switched the user, the issue persisted.

share|improve this question

migrated from stackoverflow.com May 17 '13 at 0:40

This question came from our site for professional and enthusiast programmers.

    
Do you have ~/.Xauthority file for you user? Also, why you are chowned home directory to this group? –  Sloan May 17 '13 at 9:23
    
Daniel, please familiarize yourself with our formatting options. There's no need to use HTML – and note that you need to indent code with 4 spaces. Thanks –  slhck May 17 '13 at 9:50

1 Answer 1

I had the same problem and solved using adduser instead of useradd.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.