Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to change the default font in VIM to Adobe Source Code Pro on a CentOS server (without desktop GUI). I've installed the OTF fonts in the package. How can I have the new monospace font set correctly?

Thank you in advance.

share|improve this question
add comment

migrated from stackoverflow.com May 17 '13 at 9:27

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 3 down vote accepted

In console mode, Vim is using the current font of your terminal. So you have to find out on your system, how to modify it.

share|improve this answer
add comment

As mentioned in another answer, the choice of font in a terminal application is not chosen by vim, but rather the system settings. Assuming you want to change the font for the entire system's consoles, you can take a look at this link from the ArchLinux wiki. While this is specific to ArchLinux, you will find this article (and most of the articles in that wiki) to be informative and applicable to many flavors of GNU/Linux. If you are trying to change the font used by an X windows terminal application, such as gnome-terminal, sakura, or xterm, you will either need to consult that application's documentation or set the X windows terminal font. This link has some details on accomplishing that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.