Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have searched many related questions on various sites but found no solution for this variation of the problem.

I have a filetype (.vlm) located on a network drive, and the program I use to open it is installed on my Windows XP, SP3 computer. The file CAN be opened from inside the program, but if I navigate to the file through explorer and try to open, I receive the message that is it not a valid win32 application.

additional notes:

  • I have already assigned the program to open all .vlms.
  • I'm fairly certain the program is very old - 8-bit, since files can only be saved with no more than 8 characters. Ashlar DrawingBoard is the program.
  • I know there is a simple fix, but I cannot find it.

Thanks in advance

share|improve this question

migrated from stackoverflow.com May 17 '13 at 20:42

This question came from our site for professional and enthusiast programmers.

1  
It sounds like your registry settings in HKCR\.vlm are wrong. –  SLaks May 17 '13 at 20:31
2  
8.3 file names have nothing to do with 8-bit software, not that XP would even support the latter. –  Karan May 17 '13 at 22:20

1 Answer 1

Is it really .vlm or it is .vlm.exe Because this error occurs when a windows application is run having an invalid file format.

Goto folder options in windows explorer and uncheck the checkbox hide file extension for known file types

Now with this setting the file extension will be shown for all files and if the .exe appears then just rename it to .vlm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.