Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use Apache2 in Vista. I downloaded it and installed it. I did not install it as a service though.
I see in the Start a Start Apache in console new button that seems to work. I.e. when I put in the http://localhost/ I see the default apache page indicating that it is running.
Now I have various problems trying to use cgi scripts and I started to look into the installation and I can't understand the following:
The %APACHE%\modules directory does not have dlls. There are only .so files. Isn't this wrong? Shouldn't there be dlls?
The %APACHE%\logs file has a single log file, namely the install.log.
I noticed that when I am in certain directories I see a button named Compatibility Files.

enter image description here

When I press this button (what is this button???) another directory opens in the tree that seems to have the same structure of the apache installation.And in this place I do see the apache's error log. And also the scripts that I placed from cgi-bin.

enter image description here

enter image description here

I tried to start the apache my self from command prompt but got an error:

C:\Program Files\Apache Group\Apache2\bin>Apache.exe -k start [Sat May 18 11:30:02 2013] [error] (OS 2)The system cannot find the file specified. : No installed service named "Apache2".

Is this normal or is my installation messed up?

UPDATE:

I noticed the following:
If I update a cgi file under %APACHE%\cgi-bin then a corresponding file appears in the directory under Compatibility Files.
If I delete the file visible under the Compatibility Files view i.e. AppData\Local\VirtualStore\Program Files\Apache Group\Apache 2\cgi-bin\ then the file under the original Program Files returns to how it was before I modified it!
I.e. my modifications are lost!!!

share|improve this question
1  
Ah, the wonders of virtualization. :/ –  Karan May 18 '13 at 15:44
    
@Karan:Had no idea about this.But how is it possible to not have write permission in the program files?I am the only user and therefore the administrator. –  user65971 May 18 '13 at 17:51
    
To simplify, since Vista an admin user is not the machine Administrator (to protect people from themselves). See support.microsoft.com/kb/555910 for more. –  Karan May 18 '13 at 18:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.