Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Netgear SRX5308 router with DHCP enabled as follows:

Router IP 192.168.1.1
Subnet Mask 255.255.255.0
Start IP 192.168.1.100
End IP 192.168.1.254
DNS 1 192.168.1.71
DNS 2 192.168.1.72

Then I have a Linksys N900 Smart Wifi router, which is connected to the wired router above, again with DHCP enabled as follows:

Router IP 10.78.84.247
Start IP 10.78.84.100
End IP 10.78.84.149
DNS 1 192.168.1.71
DNS 2 192.168.1.72

So when a wireless client connects to the wifi, it gets an IP range specified for the wifi router, everything seems to be working fine, the clients properly use the DNS.

The wifi router comes with a Samba server, it lets us do NAS with USB hard disks, the problem is on wired computers 10.78.84.247 does not resolve, why is that and how can I fix it?

share|improve this question
add comment

1 Answer

It is because both Routers are doing NAT/PAT. The linksys has a 192.168.1.x address on it's wan interface, and then is using 10.78.84.x on its lan interface, so clients on 192.168.1.x don't know anything about 10.78.84.x, and any attempt to contact them will generally be forwarded to your default GW (Which is your upstream internet connection) To solve this what you want to do is turn the N900 Smart Wifi router into a bridge, telling it to not do address translation or routing. If that isn't possible in the settings, you can disable DHCP on it and instead of plugging the the WAN link into the 192.168.1.x network, plug a LAN port in there. That way clients on both wireless networks will get 192.168.1.x addresses.

IF that isn't any option or you want to keep the networks separate. you need to disable address translation on the linksys, and enable routing between the 2 subnets. Then either on the netgear, or each of the computers on 192.168.1.x you will need to add a static route for 10.78.84.0/24 (255.255.255.0) to the ip address of the wan port on the N900.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.