Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 pc's. One of them have a broadband internet connection. Now for the second pc I connect it wirelessly to the first through a wireless USB adapter. I set up the the first pc to act as a proxy server and use it for internet sharing to the second. So far so good.

Now I have an android phone which I would also like to connect to internet through the second pc. I know my D-link wireless usb adapter supports Wireless Hosted Network i.e. it can be a Hotspot as well as a client simultaneosly. I started the hosted network using these commands

netsh wlan set hostednetwork mode=allow ssid=Test key=abcd1234

netsh wlan start hostednetwork

Running these commands shows up the Microsoft Virtual Wifi Miniport adapter in Network Connections. The hosted network is visible and connectible from the phone.

The problem is I cannot connect to these two wifi connections simultaneously, i.e. If I first connect to the pc wifi network and then start the wireless hosted network then the pc network disconnects. Reverse happens the other way round.

I have read that is is possible to virtualize a physical network adapter into two virtual ones and use them simultaneously. However it is not working in my case. I would like to know what can be the solution ?

EDIT: When I run the netsh wlan show drivers command , I get the following output

Interface name: Wireless Network Connection

    Driver                    : D-Link DWA-125 Wireless N 150 USB Adapter(rev.A2
)
    Vendor                    : D-Link Corporation
    Provider                  : D-Link Corporation
    Date                      : 28-04-2011
    Version                   : 3.2.1.0
    INF file                  : C:\Windows\INF\oem52.inf
    Files                     : 4 total
                                C:\Windows\system32\DRIVERS\Dnetr28u.sys
                                C:\Windows\system32\drivers\vwifibus.sys
                                C:\Windows\system32\RaCoInst.dll
                                C:\Windows\system32\RaCoInst.dat
    Type                      : Native Wi-Fi Driver
    Radio types supported     : 802.11b 802.11g 802.11n
    FIPS 140-2 mode supported : Yes
    Hosted network supported  : Yes
    Authentication and cipher supported in infrastructure mode:
                                Open            None
                                Open            WEP-40bit
                                Open            WEP-104bit
                                Open            WEP
                                Shared          WEP-40bit
                                Shared          WEP-104bit
                                Shared          WEP
                                WPA-Enterprise  TKIP
                                WPA-Enterprise  CCMP
                                WPA-Personal    TKIP
                                WPA-Personal    CCMP
                                WPA2-Enterprise TKIP
                                WPA2-Enterprise CCMP
                                WPA2-Personal   TKIP
                                WPA2-Personal   CCMP
                                Vendor defined  TKIP
                                Vendor defined  CCMP
                                WPA2-Enterprise Vendor defined
                                WPA2-Enterprise Vendor defined
                                Vendor defined  Vendor defined
                                Vendor defined  Vendor defined
                                Vendor defined  Vendor defined
    Authentication and cipher supported in ad-hoc mode:
                                Open            None
                                Open            WEP-40bit
                                Open            WEP-104bit
                                Open            WEP
                                WPA2-Personal   CCMP
                                Vendor defined  Vendor defined
share|improve this question
    
try the Ralink RT2870 driver from here: station-drivers.com/page/ralink.htm. This is the latest driver I can find. In the .inf I see your card as supported device. –  magicandre1981 May 19 '13 at 3:51
    
@magicandre1981 That was definitely the latest driver, but installing it did not fixed the issue. –  Extreme Coders May 19 '13 at 5:39
    
@magicandre1981 Thanks, for providing me the link to the latest driver, previously I was using the old d-link drivers that came bundled with the cd. The new driver enabled a lot of new features. –  Extreme Coders May 20 '13 at 7:17

1 Answer 1

up vote 0 down vote accepted

Finally after a lot of research, I figured this out myself.

The reason I could not connect to the two wifi networks simultaneously was that the pc to pc network was a ad-hoc network and the pc to mobile network was an infrastructure one. So I think that one could not connect two different network types at the same time. What I did was change the pc to pc network type to infrastructure mode, and then I could connect the mobile to the second pc, and everything worked no disconnection problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.