Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to make my Mac follow behavior I know it must have done in the past where, when one presses ⌘ + A, it will select all the text.

The problem has started recently and I think it might be related to Snow Leopard. I had several InputManagers in Leopard but I've gotten rid of all of them before I installed Snow Leopard.

The problem only seems to affect Cocoa Text Field objects but I'm not certain.

It doesn't work in Xcode, TextMate, TextEdit, and Adium... Probably others that I haven't realized yet as well...

Any advice on how to go about re-enabling this functionality would be greatly appreciated and I apologize for my English it's not my first language.

share|improve this question
add comment

1 Answer

My guess that some something is grabbing Command-A. The problem is finding out what.

When you open the Edit menu, do you still see “Select All ⌘A” as a menu item?

Look through the shortcuts in the shortcuts tab of the keyboard pane in System Preferences. If there is something defined for Command-A there, it will take precedence.

Logout and then login again, but holding down Shift right after (or while) pressing Return. This will prevent the auto-launching of your Login Items (see the Login Items tab in the Accounts pane of System Preferences). Now check to see if Command-A works. If it does, the problem is probably one of your Login Items. You can try launching them one-by-one by double clicking them in the Login Items tab. Check your Command-A functionality after each one. When it stops working the most recently launched app is to blame. Go check its configuration. It is probably something innocent like a launcher or shortcut app that has been configured incorrectly.

It could also be the keyboard itself. Have you tried another keyboard or the other Command key? You might try launching the Keyboard Viewer to check if it is reporting the key presses. In System Preferences, goto the Universal Access pane, pick the Input Menu tab, check Keyboard Viewer, check Show input menu in menu bar, then pick Show Keyboard Viewer from the new menu item (it may look like a flag) in the menu bar. To get rid of the new menu item, Command-drag it off the menu bar or uncheck the ‘show in menu bar’ option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.