Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

An example just showed up on here:

http://superuser.com/questions/59732/command-key-a-doesnt-work-to-select-text-in-several-mac-text-edit-fields

I see the text as starting with a ( followed by a square that has 23 on top and 18 on the bottom and the same thing shows up in the first paragraph of the body.

I have seen this sort of thing at various places around the web, it seems to happen mostly in things I believe were prepared in a word processor.

When it happens it can at times happen so much that the page is hard to read. Many of the offending boxes (they don't always contain the same numbers) seem to occur where apostrophes should be.

Google seems to say this is what Firefox does when it can't render a Unicode character but why is this happening and what can be done about it?

Edit: The answer I accepted fixed only some cases, not all of them.

Some examples that remain: ’“”

By context I think these are an apostrophe, an opening quote and a closing quote.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

That's most likely an error with a missing Unicode font. I had this, too and I found the best way to solve this is to install the Arial Unicode MS font (ARIALUNI.TTF) which has a size of 22 MB and is shipped with Microsoft Office and Microsoft FrontPage.

share|improve this answer
    
That did it. I'm running Firefox in a VM that doesn't have much installed in it and so I didn't have that. Problem fixed. –  Loren Pechtel Oct 24 '09 at 17:22
    
Correction--that did the example with the command key but I'm still getting quotes and apostrophes that don't work right. –  Loren Pechtel Oct 24 '09 at 22:33

If you're referring to East-Asian characters, there's page on wikipedia to help with this: Help:Multilingual support (East Asian)

That doesn't help displaying the "Command"-character used in the posting on superuser.com to which you linked.

share|improve this answer
    
I am NOT referring to East Asian characters--I have that installed as maybe once a year or so I get an e-mail in Chinese. –  Loren Pechtel Oct 24 '09 at 17:15

Quotes and apostrophes display incorrectly on many websites regardless of the browser. This happens when the web browser fails to report the page encoding correctly and the browser guesses incorrectly. The best solution is usually to ignore it, but, failing that, you can change the encoding. ̈This is under View -> Character Encoding. Try some of them and see what works.

share|improve this answer

The three particular points you mention, , , and , belong to a range that is supposed to be read in an old encoding, not Unicode. You would have to change it to another one. I believe that if you want them to be quotes and an apostrophe, you would have to change it to some Western encoding, but I don't know which. Go on view > Character Encoding > More Encodings > Western European.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.