Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently gotten an AMD Sapphire HD 5970 2GB video card. This seems to consist of two 1GB cards on the same chip (there is a crossfireX option but the card otherwise has only one PCI-E connector)

When running some DX11 games, there is flickering (moving horizontal black lines) or garbled characters, but this only happens on things that are 2d (splash screens, fonts...) and only in fullscreen mode ("windowed borderless" does not seem to have this error).

3D display seems to work fine. I have already done a lot of googling on this issue, so here is what I already tried:

  • Using MSI afterburner to increase the clock speeds
  • Disabling Ultra Low Power State mode
  • Editing the AMD profile to increase "2d clock" to 400/900Mhz as described here.
  • Performing various benchmarks (furmark in fullscreen mode, no issues at all, temperature/fps are okay)
  • Various video card 3d settings. Performance, lower/higher quality, ambient occlusion, etc.
  • The card is out of warranty. I have taken the card apart, cleaned it from dust and applied new thermal grease. Problem persists.
  • All windows updates are installed
  • I have tried the 13.4 drivers as well as the latest 13.5beta2 drivers
  • Updated to the latest BIOS but no change
  • I also tried disabling CrossfireX, but this has no influence on it

When running anything in DX9 mode, this issue does not occur. It only affects DX11 stuff, but it does not seem to be connected to settings. Turning all effects off still causes it to appear.

Here are my relevant hardware stats:

Operating System: Windows 8 Pro 64-bit (6.2, Build 9200) 
Motherboard Name: MSI 970A-G43 (MS-7693) 
BIOS: BIOS Date: 03/28/13 16:31:10 Ver: 04.06.05
Processor: AMD FX(tm)-8150 Eight-Core Processor            (8 CPUs), ~3.6GHz
Memory: 8192MB RAM
Video Adapter: Sapphire Radeon HD 5970   (2 GB)

Here is a sample, from The Secret World: enter image description here

As you can see, the menu on the left is garbled, and the characters are also blinking. The rest of the text seems fine though, apart from when new text appears on the screen.

Unfortunately, I was unable to take a screenshot of the Final Fantasy XIV: A realm Reborn benchmark, as it would not let me take screenshots, but I get moving flickering black bars across the splash screens, but no errors at all during the 3d parts.

I am open to any suggestions or advice.

share|improve this question
Have you tried it in another computer? If it behaves the same way, it's busted. – Ƭᴇcʜιᴇ007 May 19 '13 at 15:14
@techie007 The card is 133mm long. It does not fit in any other case I have. But why would this only happen on fullscreen an "windowed borderless" would run fine? Or DX9? If the card was busted, it would have display issues every time. – Satoh May 19 '13 at 17:54
I have the same issue with my new Radeon HD 7970. Games that work: Mortal Kombat and Dungeons and Dragons: Chronicles of Mystara. Games that don't: Guacamelee, Bleed, Incredipede, and pretty much everything else I've tried. – Sawtaytoes Sep 8 '13 at 6:11
possible duplicate of Horizontal lines flash randomly over laptop display – Rosenthal Sep 29 '14 at 23:32

Change your Power Plan settings

The power plan is limiting the resources for the graphics card to function properly. Change all the settings to the Maximum Performance.

How I fixed the problem:

  • Install the latest drivers from the official AMD website (Catalyst 14.0+).

  • Change you Power Plan to High Performance (in battery and plugged-in).

  • Go to Control Panel>Power Options>Change advanced power settings> ATI Graphics Power Settings> ATI Powerplay settings> On battery, Plugged in: Maximum Performance.

  • Go to Control Panel>Power Options>Change advanced power settings> PCI Express> Link State Power Management> On battery, Plugged in: Off.

  • Disable Aero (Choose the Windows 7 Basic theme)

  • Restart your PC.

Important: This will also fix a constant change in the brightness level when you switch between dark and bright apps.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .