Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Attempting to hand over my external HDD to a friend of mine for his use, I deleted all the files in my external HDD amount to freeing space close to 470GB. I did it all in my mac. For all I remember, some files I deleted using Windows machine and some others using my Mac machine.

I tried finally formating or doing quick erase using the disk util. Since then, the HDD is showing up only 149Gb as the total capacity of my external HDD.

Not sure what has happened. Please help me recover the full capacity of the HDD.

Thanks in advance..

share|improve this question

migrated from stackoverflow.com May 19 '13 at 18:38

This question came from our site for professional and enthusiast programmers.

    
Did you delete all of the partitions? What file system did you format it as? –  Blender May 19 '13 at 18:37
    
The HDD had only a single partition in DOS format (FAT 32), a reason I could use it freely with my windows and mac machine. Some more information: The external HDD was disconnected in the middle of first format which is ExFAT. I then tried formatting it using NTFS format via my Windows machine again. This didn't help. Lastly, I tried formating the disk again using my mac's disk utility software for ExFAT format. And I now only have 149GB as HDD capacity :( –  karthiks May 19 '13 at 18:51
    
I don't know much about ExFAT but Wikipedia says it's for SSDs. Why are you using it on your HDD? –  Tom Dworzanski May 19 '13 at 19:10
    
What is the output from [start] [run] diskpart "answer YES to UAC", list disk? It should show a list of detected drives with their size in the third column. If that shows 500GB, use a 'select disk X' (with X being the disk number of the external drive. Double check that!), then use the command clean to wipe all old info followed by a create partition primary and a format. –  Hennes May 19 '13 at 19:17
    
If it still shows up as 149 GB, try checking the Host protected area with HDparm. (E.g. after booting from a gparted liveCD. –  Hennes May 19 '13 at 19:27

2 Answers 2

Sounds like you created and formatted a 150GB partition and left the rest either unformatted or formatted using a file system that cannot be read.

You should reformat your HDD, first deleting all the partitions, and then formatting the entire empty space.

share|improve this answer

There is a program called MiniTool Partition Wizard, which has a lot more options than the disk utility.

It lets you view existing partions, and you could probably try formatting the drive from the program. The only thing I can think of is that there still may be an existing partition. Best of luck!

share|improve this answer
    
Thanks. After all things failed, I did try this one. It only shows 149GB as the external HDD capacity :( –  karthiks May 19 '13 at 18:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.