Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I typed $fdisk -l into the terminal to see my partitions.

When I installed Linux I installed it on sdb, which shows up, but for some reason it says Linux under sdc.

This is what it looks like.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   ?  1919230059  6204919772  2142844857    a  OS/2 Boot Manager
/dev/sdb2   ?   544829025  1089655755   272413365+  65  Novell Netware 386
/dev/sdb3   ?   168653938   168653938           0   65  Novell Netware 386
/dev/sdb4      2885681152  2885734080       26464+   0  Empty

Now sdc:

/dev/sdc1   *        2048      976895      487424   83  Linux
/dev/sdc2          978942  1797851135   898436097    5  Extended
/dev/sdc5          978944    30273535    14647296   83  Linux
/dev/sdc6        30275584  1788086271   878905344   83  Linux
/dev/sdc7      1788088320  1797851135     4881408   82  Linux swap / Solaris

The reason I'm digging into this is because I'm trying to get my Linux Mint option in my Windows boot manager to work. Currently it just says "Windows failed to start", when I click on my Linux in the boot manager.

Although I can still get Linux to run, because when my external Hard Drive is plugged in with Linux on it, and I click on Windows 7 in the boot manager, it runs Linux.

share|improve this question
1  
The disk assignment can float with different disks added/removed (installation media, for example, can make the system enumerate them differently). For that reason, UUID is starting to be more commonly used when supported (for example, in fstab). That being said, are you open to using the GRUB loader instead of Windows Longhorn, or do you specifically want the windows bootloader? Did you do the WUBI install or boot into an installer medium? –  nerdwaller May 19 '13 at 20:52
    
Are you trying to add a Linux option to your Windows Boot Manager to boot Linux off of an external hard drive? It's probably going to be much easier if you just directly boot off of the hard drive instead, pressing F12 (Dell) or similar on bootup to select a boot device. –  ultrasawblade May 19 '13 at 21:06
    
@ultrasawblade The hard drive is not recognized in bios. –  Bradley Mitchell May 19 '13 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.