Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

every time I try to install something or just simply use apt-get update I get an error saying something about Unmet Dependencies.

root@xxx:~# apt-get upgrade
Reading list of packages... Ready
Building dependency tree
Read information about status... Ready
You might want to run "apt-get -f install", to correct these:
The following packages have unmet dependencies:
 mysql-server-5.1 : Requires: mysql-server-core-5.1 (= 5.1.61-0+squeeze1) but 5.1.63-0+squeeze1 is installed
E: Unmet dependencies. Try to use -f.

How can I fix this? And because of the fact that it has something to do with mysql (I'm running website and game server) do I have to do a backup and should I be worried about my databases?

share|improve this question

It looks like mysql-server is requesting an old version ofmysql-server-core. Remove the version you have currently (5.1.63-0+squeeze1) and install the version it is requesting (5.1.61-0+squeeze1). Back up any important files.

share|improve this answer
What command should I use for that? apt-get remove mysql-server-core and apt-get install mysql-server-core-6.1.61-0? – Daniel Kmak May 19 '13 at 22:13
That would do the trick I think, but you might want to use -f on the uninstalling so your base package mysql-server won't be uninstalled. I dont know the specific syntax, so I suggest looking it up. – Wolfizen May 19 '13 at 22:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .