Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have encountered a problem that I cannot seem to find any way around. So I turn to you for help. Read carefully, because this is not the regular “BOOTMGR is missing” problem…

I have a PC where I had one HDD with two partitions (C: and D:) and Windows XP installed on C:. Then I installed another HDD (G:) and on this one I installed Windows 7.

After this I got a boot screen every time I started my computer, asking me if I wanted to boot Win XP or Win 7. And that worked just fine.

Drive 0: 
* Volume C:  XP
* Volume D:  Data

Drive 1:
* Volume G:  win 7

After some time I decided that I had no use for Win XP anymore, so I deleted that partition and made the whole space on that disk available for the D: partition (still named D:). This because I use the computer for making music, and I had numerous music programs and projects pointing at files on D:.

At first everything worked just fine, my computer booted up nicely in Win 7, without any boot menu.

But just recently I had to remove my on board memory and then reinstall them again. After that, when attempting to boot, I get the message: “BOOTMGR is missing” message, every time I try to start my computer.

I have tried to solve it by using the installation CD. Booting from that, and then choosing “System Repair”. After that I just get a message that there is no Windows installed on this computer. Can someone please help me? I’m stuck here.

share|improve this question
1  
Which disk is the primary boot disk in the BIOS? Is it possible that after removing the C volume it was set to boot from drive 1, and that this got reset while you did hardware work on the memory? (You can test that by pressing F12 or whatever key your BIOS uses as the boot menu and then try to boot from both disks). –  Hennes May 20 '13 at 0:14
1  
Another possibility is you dislodged the SATA cable for G: when inserting the RAM. Check that the bios sees both disks. –  Paul May 20 '13 at 1:57
    
Hennes, first off all, tnx for editing my post. Now it looks nice. By primary boot disk in bios, do you mean that it should be the first disk int the boot sequence in the bios setup? And Paul, yes both disks are available in the system bios setup. –  PoP May 20 '13 at 11:16

1 Answer 1

This ought to fix it:

  1. Disconnect Drive 0

  2. Connect Drive 1

  3. Run Startup Repair from a Win7 Setup DVD/USB

  4. Reconnect Drive 0

  5. Ensure primary boot device in BIOS is set to Drive 1

share|improve this answer
    
Thanks for all the answers, I love you all! –  PoP May 22 '13 at 1:38
1  
Half off the thing did it for me ;) I just changed the boot-order, so tyhat it booted up from the right drive. That did it for me. I cannot belive that Windows/Microsoft is that stupid... –  PoP May 22 '13 at 1:41
1  
@PoP: if you're booting to a drive without the Windows boot loader installed on it, how is Windows supposed to boot? :-) –  Harry Johnston May 29 '13 at 3:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.